Trouble restoring from automatic backup

This discussion was created from comments split from: Undo - Delete collection.
  • If I have a backup of my file directory -- storage showing all file keys, how can I import that folder back into my Zotero library after accidentally deleting my largest collection? I tried following the renaming protocol above ^ but it didn't restore my automatic update.
  • You'll need to say more. The restore instructions work if you follow them precisely.
  • I think the problem is that auto-sync updated the .bak files so when I purportedly restored that large KB file, it did so, but to an updated version (after I lost the original). What I'm referring to above is in my data directory, my storage** folder has individual keys of all the records I need but I don't see how I can import them all in one; instead, it might be able to be done one by one but it's over 2k records.
  • The instructions specifically say to disable auto-sync. Again, if you follow them precisely, you'll be able to restore from the backup.
  • I did disable, but the auto backup hasn't worked. Any ideas?
  • I don't know what "hasn't worked" is supposed to mean, but I promise you the instructions are correct. You can see the timestamps of the backup files in your filesystem. When you restore correctly, you'll restore your database to its state at that time.
  • Ok let me be clear because it seems that I am not.

    1. I read the directions. I disabled auto-sync and proceeded. I checked the timestamps, made copies of .bak files, and renamed the original .old and the sqlite (that exists as my restore copy)., I then re-opened Zotero and nothing changed. I was renaming files within the file directory while Zotero was closed. However, no changes.

    Is it possible that I can try this again, or do you suspect it is possible they'd been overwritten?
  • edited May 18, 2024
    You can just close Zotero, move zotero.sqlite out of the way, and restart Zotero to confirm that you're touching the right file. If you do that, Zotero should start up with an empty database.

    Once you have an empty database, you can close Zotero again, delete the empty zotero.sqlite (which will be either 1 MB or 5 MB), and try swapping in the bak files to see what they contain. But whether they have the data you need depends on when you exactly made the change in question and whether it was before or after the timestamps of those files. Those files are just copies of your database from that time. There's nothing here that can possibly not work. If you don't see the right data, it didn't exist in your library when the backup was made.

    Note, also, that if this is just about a deleted collection (which I gather from another thread of yours), the items in the collections are likely just in your library root and not deleted, so it may be easier to just recreate the collection.

    A future version of Zotero will make it possible to restore a collection from the trash.
  • edited May 18, 2024
    Also, to be clear, you would have to be copying in the original, unmodified backup files. If you swapped them in without disabling auto-sync and then it synced, those files would've been updated with the changes you made previously.
  • Regarding your most recent message ^^ I think** that's what happened. I will try again and come back.
Sign In or Register to comment.