iPad sync failed (FAILED API RESPONSE: no response)


I reached the sync quota but upgraded. Had to update password because id forgotten it. I am able to access the files in my iPad and I can see them on my Mac but it says file not found (at the following path) when I click it on my Mac.

Please could you help fix?
  • Hi,

    thanks for reporting. Does this issue still occur to you? Did anything change?

    This issue happens because you added an attachment to your library and something broke on our side. Do you remember how you added new attachments before it broke? Did you add it manually by going to item detail and tapping "Add Attachment"? Or did you only add via share extension (by tapping share button in Safari for example)?

  • Hi,

    Thanks so much for helping with this :)

    I do not remember adding any adding any attachment to my library. If you mean the file, I added the file from my iPad on my iCloud.


    I am still getting the sync failed error message on my Ipad and the files are still unclickable on my laptop, just pulls back a File not Found error (see image attached)

    please advise, and thanks again for your help
  • There was also a bug with iCloud and it randomly duplicated and changed the name of some folders and deleted files from the original and put into the new one.

    e.g. original icloud files:

    MPBDS (2)

    With most files and folders moving to the second folder. Could this be causing the sync issue? If so, how do I update the folder on my iPad for the cloud to sync?

    thanks so much
  • Can you try to:
    1) Terminate the Zotero app (in app switcher swipe up on Zotero) and try to sync again.
    2) Try restarting your device and try to sync again.

    If that doesn't work can you please send me another debug id of a sync (same as you did above)? Thanks.
  • Thanks so much for all the help!

    I have tried both actions and I am still receiving the same error message on my iPad: D1207980733

  • Can you try adding a different file from your iCloud to Zotero? Just to see whether this issue occurs for every file or just for that specific one. Thanks!
  • thanks!

    There are quite a few files that I am experiencing this issue with. on the right side of the attached image, you can see the files that I can open on my mac versus those i cannot. For the one in this folder that i can open, the small pdf symbol is shown in a darker colour, and the ones that I am unable to open are showing in a lighter colour


    Also screenshot shows how i am adding files (you asked earlier and i reaslied i didn't answer that. Most often, on Ipad, I click + then add file.


    I have uploaded another 2 articles via my ipad. After syncing, the article titles appear on the list on my mac, but they are not clickable, it pulls back the same error.

    thank you!
  • Also Not all the articles appear in Zotero mobile, they do t even appear int he clickable form that they appear on my mac

  • @sachasoares can you explain a bit more? How did you add those files? You added them on iPad or Mac? And you can't open them on iPhone but you can open them on Mac?
  • sure!

    I added these files on my iPad. Using the add file function in the folder.

    I used to be able to see files added through my iPad on my mac.

    Last week, suddenly, it seems that many files previously added through my iPad are no longer available to open on my Mac, although they do appear in the list (but greyed out).

    I can still open them on my iPad.
    They appear on my mac zoterro, even new items which i added via my ipad since this issue began I am able to see in the list on my Mac, but the pdf icon appears greyed out compared to other files which were I can open, so I assume may have been added via my mac. when i try to click on these greyed items on my mac, it pulls back an error, it won't open.

    Oh, update, the files do now appear on my iphone, but a little question mark appears next to the pdf symbol, and when i try to click on them, it gives me an error: 'the attached file is not available in the online library. please check that the file has synced on the device where it was added.

    When i try to sync on Ipad, it pulls back the failed API response error.

    The 1 item in the list that i am able to open on my mac, (01a-shared-novelty..') i am not able to open on my iphone.

    I can't remember whether I added this file on my mac or my ipad, but it was already open on my mac, so either i added on my mac originally or perhaps the fact that the pdf was already open stopped it from being 'lost'?

    Last week I received a message saying that I had used up all my free storage on Zotero, so I upgraded to the paid version. I'm not sure whether this issue syncing happened before or after but it was roughly around the same time.

    Should I try signing in/out of zoterro on my mac/ipad? Should I redownload? I am afraid to lose all the highlights and annotations I've done as this affects a large number of files (not just the ones in this folder)
  • Could it be because I updated my password?
    How do I update password on ipad without losing the data?
  • sorry for the multiple posts, but I had a Further update,

    The items appear in the online library, but in an unclickable/unopenable format, just like my mac.


    The item I can open in my mac, can be opened in the online library.


    it looks like the file name etc syncs to online library but nothing else, not sure what might be causing this?
  • OK, thanks.

    First, to clarify:
    Last week, suddenly, it seems that many files previously added through my iPad are no longer available to open on my Mac
    This isn't correct. Nothing became unavailable. The files were just never uploaded from the iPad, so they're not available on other devices (Mac, iPhone, or web library).

    We were confused by some of your previous statements, but all of this checks out and is consistent with this just being a problem uploading files from the iPad.

    Are you syncing the iPad from the same network as your Mac? Basically, the upload requests from the iPad to the Amazon cloud are timing out, and we're trying to figure out why. We fixed a potential cause of this in the last app update, but it's not impossible that Amazon would continue blocking requests from a given IP address for a period of time. So if the iPad has been on a different network from your Mac, it would be worth trying to sync from elsewhere. But if you can add new files on your Mac and sync those (such that they become available in the online library) from the same network as the iPad, then it's a bit weirder that only your iPad is affected, and we'll need to keep investigating.

    Beyond that, the only outlier is this:
    The 1 item in the list that i am able to open on my mac, (01a-shared-novelty..') i am not able to open on my iphone.
    That file exists online and should be accessible on all your devices. What exactly happens when you try to open that from your phone? Can we see a Debug ID for that?
  • WOW!! Thank you!!

    Based on your advice, I have tried syncing the ipad files using another internet connection, and instantly the problem is fixed!! thank you!!

    I am now able to access the files on my mac and iphone in addition to my ipad.

    The internet connection that would not allow me to sync my ipad is my home wifi, and thsi will be a problem if i am not able to sync pdfs at home.

    Is there a way to rectify this issue for my home wifi?, or as you say 'it's not impossible that Amazon would continue blocking requests from a given IP address for a period of time.', would it mean this issue should resolve by itself after some time?

    thanks so much!!
  • OK, great — so at least it's totally clear what's happening.

    This should definitely resolve itself, though it's hard to say when. It's actually rather surprising that this is still happening, since it's been a week or more since the previous version (and the bug in the previous version wasn't, like, launching an attack against Amazon — it just could make some file-sync requests that weren't authenticated properly).

    One easy thing to try would be unplugging your modem and router. On many residential internet connections, that will get you a new IP address. If that doesn't help, the best we can suggest is to wait a few more days.

    Sorry for the trouble.
  • Thank you so so much!!
Sign In or Register to comment.