plugin for open office

I can't see the zotero plugin/toolbar. I have successfully installed the extension. The cite extension shows it has been installed. The manual install warns me it is already there. On manual install I can access the extension manager. But there is no zotero toolbar to use in open office or libra office. Latest versions. Restarted computer and programs. Zotero is working fine. My libraries are fine. I can add and use zotero fine. I just can't see the extension from the word processors. What am I missing here? Thanks.
  • We haven't supported OpenOffice in years. You should be testing with LibreOffice 7.6 or 24.

    Are you saying if you go to Tools → Extension Manager in LO, you see Zotero LibreOffice Integration installed? What version?

    Do you not see Zotero in View → Toolbars?
  • I have LibreOffice 7.6. No, I cannot see Zotero in View--> Toolbars.

    However, I also have OpenOffice 4.1 installed. In the extension manager for OpenOffice, it shows that Zotero LibreOffice Integration is installed, version 5.0.23.

    Neither of the word processors show the toolbar however.
  • Should add that in LO Tools--> Extensions does not show Zotero LibreOffice Integration installed.

    Not sure how to install as it says I have it installed, but doesn't seem to show.
  • Again, OpenOffice isn't relevant. We only support LibreOffice. You should remove the extension from OpenOffice and stop trying to use it there.

    If you don't see the extension in the Extension Manager in LO, see Zotero Toolbar Doesn't Appear and the platform-specific steps linked from there, and if you're still having trouble, let us know exactly what you tried, in your own words, and what happened at each step.
  • Still nothing appearing. I checked the cite pane in preferences and confirmed LibreOffice was installed. Add-ons in Zotero has LibreOffice enabled. Did the restarts. Did the manual installation. No Zotero toolbar. No toolbar that shows Zotero. Unless...I just am missing it somehow? Where is the Zotero toolbar supposed to appear and what does it look like?
  • edited 3 days ago
    Can you provide screenshots of the Extension Manager in LO with the plugin installed, the View → Toolbars menu, and the LO About dialog?
  • edited 3 days ago
    But that just means you haven’t done the manual installation in LO at all.

    Either get rid of OO, which I would recommend, or install the .oxt manually in the LO Extension Manager.
  • It was added manually and I saw no change. This is what add-ons in Zotero say:
    https://s3.amazonaws.com/zotero.org/images/forums/u14290425/fgw1v2z38xk0klk0gd1u.png
  • This is Zotero's cite tab. The request is to install Zotero's LibreOffice extension directly through the LibreOffice add-on manager using the .Oxt file as described in the troubleshooting
  • @tom.14: The manual installation instructions say to double-click on the .oxt to install it, but if OO is the default handler for .oxt files on your computer, you'd obviously have to click "Add…" in the LO Extension Manager and select the file yourself so that the extension is installed and appears there rather than in OO.

    But that's also why I'm suggesting to just get rid of OO — it's likely causing both the installation from Zotero and double-clicking the .oxt not to work as expected.
  • edited 2 days ago
    Okay thanks. When I check properties of the extension, it says OO, so I assume then that is where the problem lies. When I try the manual install from LO extension manager I get
    https://s3.amazonaws.com/zotero.org/images/forums/u14290425/aahr7g9u8bd1fbwvcx5j.png
    Not prepared to move to OO from LO as primary, so I'll need to find another workaround.
  • edited yesterday at 5:48am
    When I check properties of the extension, it says OO, so I assume then that is where the problem lies.
    No, that's just a file association — that just means you have OO installed.

    The only reason this thread has been going on so long is because you weren't actually installing the extension into LO until now.
    Could not create Java implementation loader
    You have a broken or missing Java installation in LO. You need to make sure you've installed the Java JDK and selected it in LO:

    https://www.zotero.org/support/word_processor_plugin_troubleshooting#installation_error

    There's no "workaround" for OO. Again, we haven't supported OO in many years.
  • Okay, the Zotero toolbar now shows, but is unresponsive. There is a gap in the instructions for installing JDK:
    I reinstalled the add-in: Next, restart Zotero, open the Cite pane of the Zotero preferences, and click the Install LibreOffice Add-in button on the “Word Processors” tab.

    But there was no ask: When you are *asked* to locate your LibreOffice installations, ensure that your LibreOffice installation is listed. (You can add new LibreOffice installations by clicking the “Add Directory…” button below.)

    I have no idea what is asking me what. There was no pop up or question.
  • It's not enough to say that something isn't working. You have to tell us what's actually happening. When you use the "Install LibreOffice Add-in" button, it should start a wizard that includes a question about the path to the LO unopkg executable.

    But you're still misunderstanding this.

    All the "Install LibreOffice Add-in" button in Zotero does is install the Zotero.oxt into LO, just as Zotero tries to do automatically when you first run it. It's identical to just installing the .oxt yourself into LO. Since you have OO installed, the button probably isn't going to work, so you should stop trying.

    Same with double-click the .oxt. Since you have OO installed, that's probably going to try to install the .oxt into OO.

    All you need to do here is 1) install the JDK, 2) make sure it's selected in the LO settings, and 3) install the .oxt via the LO Extension Manager. You don't need to do anything else in Zotero.
Sign In or Register to comment.