Better BibTex translators not loading

Better BibTeX translators do not load properly, showing this;

https://s3.amazonaws.com/zotero.org/images/forums/u9163855/ag0n8rxvuz0w8zg8tqg4.png

I realised that last night, a couple of new files were added to the better bibtex translators folder: 'Springer link.js' and 'EBSCOhost.js'. Everything was running just fine before this morning.

I use Windows 11, and I have installed the newest versions of Zotero and all add-ons.

Not sure what other information I should bring here. Please let me know.

Are there any solutions to this?
  • For problems with a plugin, you'll need to contact the plugin developer (in this case on GitHub).
  • There is no "Better bibtex translators folder"; Better bibtex adds translators to the zotero translators folder. If BBT fails to initialize, I will need to diagnose why. Please do open an issue on github.
  • Thanks for the feedback.

    I actually managed to resolve the issue by disabling and enabling the plugin...
  • If it happens again, please send a BBT debug log before you do - if there's a problem, I want to solve it.

  • https://s3.amazonaws.com/zotero.org/images/forums/u6509903/850to6edv9uylnqtvvyi.png

    I have been having the same issue for the last few days. The “better bibtex translators” message hangs indefinitely (I even tried leaving it overnight to no avail). I tried re-enabling the plugin since I cannot open the BBT settings. Is there another way to get a BBT debug log that I can post over on Github?

    Most of the Zotero UI is still responsive while this is happening, but it does prevent some other plugins from running.

    I am on Ubuntu 22.04.4 LTS x86_64, Zotero 6.0.30 and latest BBT.
  • edited 9 days ago
    Yes, the issue ticket template explains how at the bottom.
  • "If the regular debug log submission does not work, use "send to file.io" from the help menu."
  • For me disabling and re-enabling fixed it.

    It seems to have been affecting display of notes; both problems cleared after re-enabling.
  • That doesn't help me fix the problem though, and I really want to fix this. The file.io fallback is present specifically for startup errors.
  • I tried the "reset translators" option under preferences > advanced > files and folder > database maintenance and that seemed to get rid of the problem. If it occurs again I will submit logs.

  • BBT seems to hang on Zotero.Translators.init() for at least one user at https://github.com/retorquere/zotero-better-bibtex/issues/2880
Sign In or Register to comment.