New issue in Beta

I am finding the "Rename file from Parent Metadata" function is no longer working. It has worked with the 7 Beta previously. I'm not sure if I did something that broke the function. I have Better BibTex installed.
  • **Update** As I was writing my response to this (which included a rant about assuming I don't know what I'm doing since those links don't actually address what I was referring to), I went to check the UI and tested one item that has been giving me trouble for days. It now works. Something changed between when I tried it last and it didn't work until now. What did change: I turned off the plug-ins. Now, with the plugins turned off, the "Rename File from Parent Metadata" now works again.
  • edited April 17, 2024
    This is very likely still a misunderstanding. The difference in the Zotero 7 Beta — that an attachment title differing from the filename is no longer changed when using "Rename File from Parent Metadata" — really is explained in those links. If you think those links don't address what you were seeing, you should explain the exact behavior you were seeing and what you're seeing now.

    (To be clear, this has nothing to do with assuming you don't know what you're doing, and a "rant" along those lines would certainly be inappropriate here. This was a major change in Zotero 7, which we're still refining, and has been a common source of confusion. If you were seeing some other bug related to a plugin that made your question different from the dozens we've received on this, that's fine, but that would be a strange coincidence and not a reason to be mad at someone trying to help you.)
  • I guess then mybe I don't understand what you're saying...because how I've been using has worked for me exactly as I would assume the "Rename File from Parent Metadata" should. I'm changing the filenames not the title because it's the filenames I care about. Just so we're on the same page: The filenames are generated automatically and following the renaming scheme I have. The metadata consisting of the title, authors, etc is something completely different. Often, a file's name will be incomplete because some piece of metadata is missing. I go in, update the metadata and then use "Rename File..." to update the file name. The file name gets updated and now I'm happy because my filenames tell me something about the file. The filename, though, is a different thing from the item title. Well, that's fine with me because I don't want it to reflect the title and this process has worked fine for me both before the beta and since. Did I miss something? Is that not what is supposed to be happening?
  • I mean -- if this is now working for you, there's no need to discuss this further, but FWIW yes, it does sound to me like you're misunderstanding this the same way folks in the linked threads did. The item title and the attachment title are not the same thing.
  • I'm just not sure where the misunderstanding is coming from.

    I know item title and attachment title are not the same thing. What I'm doing has nothing to do with making my attachment and item titles the same.

    In the hopes of trying to be more clear...Since the functionality stopped working after I have been using the beta for a while, I thought this may be of some interest.

    Here is an example. I copied this file from the database for use elsewhere. I couldn't get the name to update after changing the metadata. After disabling the plugins, the name changed - as expected.

    Before: The original filename Zotero gave it. (I have my filename pattern to be author-date-title). From Feb-today I couldn't change the name.
    Today: After disabling the plugins, the na
    me was changed. (This is the file in the storage section of the database.)

    I apologize if I'm not being clear. And please tell me if I'm not using the software correctly or misunderstanding it's capabilities. The name changing functionality is something I really appreciate and am glad there's an easy way to change these filenames so I don't have to find "s82t7815741389" every time.
  • Ok, then it sounds like you're all set.
    It's certainly possible a plugin could lock a file and prevents filename changes. If you can replicate that, report it to the plugin dev.
  • Okay. I'll try that and see what happens. Thanks for the advice. Now I'm all set.

Sign In or Register to comment.