Zotero App not responding and syncing

My Zotero App isn't responding for a few hours.... Maybe due to an overload of files? Anyway, the app also isn't syncing with my online profile. It has totally different files than on the App. How can I properly sync my account (I tried resetting but this also didn't work) and how can I use Zotero again without it "not responding"?
  • It is still trying to sync, but it doesn't work (it is still loading). I can't reset syncing in the meantime. When trying to stop syncing, Zotero is not responding... Any help?
  • Zotero is now responding, but the App stil won't sync with the online version... I have 2 totally different libraries. How to fix this? I already tried resetting
  • You have a very large library, with tens of thousands of items in the trash, which likely was causing the freezing.

    You should start by trying to purge the items from the trash, which you might need to do in batches — you can select them in the trash and press Delete/Backspace to delete them permanently.
  • I deleted the trash yesterday and that worked (Zotero is responding now), but my library is still not syncing.
  • OK, then see Changes Not Syncing and provide the info it asks for if you're still having trouble.
  • D865522678
    this is my debug ID
  • That shows an ongoing sync.
  • yes, but it show 33 minutes ago the last sync was completed. But it has never synced properly...
  • edited 21 days ago
    That's not meaningful in your case. Just let it go. It has to reconcile tens of thousands of deletions for items that seem to have also been modified remotely. It's going to take a while.
  • So you think this will eventually sync properly? Because it is already syncing for days...
  • Hello,
    I am working in the Zotero app currently and the changes I make are not syncing to the online library (group library). The last sync was 5 days ago and when I click on the sync button, it doesn't do anything. I checked if it was connected to the right library and it is, so that doesn't seem to be the problem.
    for example: I transferred an article to another map, but in the online library it doesn't become visible, the debug ID is: D1865910196
  • That still shows an ongoing sync, reconciling your tens of thousands of deletions. I'm not sure why you don't believe me when I tell you that it's syncing, but I promise you it is. If you close Zotero, it will stop syncing. You can go to Help → Debug Output Logging → View Output to see for yourself that it's doing things. If that stops, that would be relevant and we'd want to see a Debug ID, but otherwise, you really do just need to let it continue.
  • @LouiseGlenisson: You also still have thousands of items in the trash. You should empty that.
  • OK, I'll do that and hope that it will sync properly
  • In this case, it might speed things up to restart Zotero after emptying the trash. Right now it's uploading all the changes for the items moved to the trash, but once you empty the trash, it can just send actual deletions.
  • @LouiseGlenisson: It looks like you now have tens of thousands fewer items and no items in the trash. Are you all set?
  • yes, thankyou! it worked!
Sign In or Register to comment.