Inking / Drawing stops mid-writing

Hello, I'm sorry if this is already discussed somewhere else, but I just couldn't find anything related to it.

I have a "One by Wacom" drawing tablet and tried to draw on a pdf. After a few quick strokes, it stopped drawing, locked all annotations and prevented me from selecting any of the annotation options (draw, highlight, text box, etc.) - all options are greyed out, including changing the colors of existing drawings, deleting, etc.. If it helps, it seems that the last stroke where Zotero gives up ends up not being registered. Also, it seems to be related to drawing quickly, as it hasn't happened yet when drawing slowly.

After a few reproductions with the pen, I tried with the mouse as well and the same happened.

Are there any options I can change to fix this? Should I use another pdf reader for drawing annotations?
  • If you're unable to annotate, it indicates that the file is read-only. This could mean that the file is either in the trash or in a read-only group library.
  • Perhaps I wasn't clear enough. What I meant is that it works for a few strokes and then stops working.

    Could it be that there is something in Zotero triggering read-only mode after X amount of drawings in Y amount of time and then it fixes it when I re-open the file?

    Though I'll clarify that the problem occurs when writing with the drawing tablet as well as with the mouse, although more often with the tablet. After more experiments, there were also a few times where it happened with a single stroke of my pen.

    Meanwhile, I have found a previous occurrence of a similar problem on the following post - - with the difference being I do not get an error appearing as a red band.

    If there is anything else I can clarify for you to be able to reproduce it, please let me know.
  • I also still see the bug:
    Debug ID: D1932433946.
    Debug ID: D1714769555.
    Windows 10
    Zotero 7.0.0-beta.68+c31a40c74 (64-bit)
  • I am having the same issue. I use the draw function to underline some text and it works for about two or three lines and then it freezes up. I have to exit the document and then reopen it for it to work only for a few lines again.
  • We believe this is fixed in beta 73. Let us know (and provide a Debug ID) if you're still seeing it.
Sign In or Register to comment.