NYT (includes TimesMachine) & Foxnews, no snapshots for ages and...

Note that the NYT requires a subscription to view.

Hi there. I am using v. 6.0.36. and I use Firefox v. 124.0.1. There are problems when I add articles from these news agencies.

First, I no longer get snapshots from either site (I used to get both) and this is essential for me. Many articles get shuffled around and archived and I need a copy for the day I accessed it.

Second, the TimesMachine's URL field in Zotero (FYI: does download the pdf) adds something that breaks the URL. Here's an example:

See the problem?

Of course, I can fix that but it is tedious and takes up more time. I cannot see the portion of the URL that needs removing so I have to manually move my cursor for a lot of characters before I can fix it.

It also is simply incorrect. The URL should be:
At least, that is the URL in the browser's URL field. So it's missing the article number, which is not found anywhere else except the URL field in the browser, as well as the article's starting page number. You have to have both, for it to work properly.

Now the date will take you there and you can find the article manually, but the point is that it's still an incorrect URL. Naturally, I prefer not to have to edit every single article, I add to Zotero.

Anyone else have this problem?

  • For the Snapshot: That should work and does for me in Zotero 7 beta -- it's possible there's a problem in 6, but I'm not aware of that. What exactly is happening? Do you have Snapshots enabled in the (Zotero) preferences?

    For Timemachine -- The URL comes directly from the Times' metadata on the page, but it seems consitently wrong and we'll fix it.
  • I do have them enabled and it works for every other website.

    Should I uninstall and reinstall? If so, how do I back up all of my collection? I have thousands, so I need to be very careful.

    Still, I cannot understand why all other sites work, except the ones that I frequent the most.

    Thanks for fixing the URL problem in TimesMachine.

  • edited March 25, 2024
    Another problem at TimesMachine that I forgot about. The abstract does not work. Probably because of their changes, but it might (only might) work the first time but then it uses that abstract for all remaining citations I use at TimesMachine.

    I am presently backing up my entire C:\Users\\Zotero file and am considering trying the beta that so many are raving about. Do you think that may work for the snapshots? What about the TimesMachine issues?

    If I could add one more thing to the TimesMachine, I would love for Subjects: lines to be copied to the abstract, or keywords. Thanks!
  • We might not be able to get abstracts reliably for time machine.

    Definitely don't bother reinstalling, but trying the beta is worth it, yes. Make sure that all add-ons you really need are compatible with Zotero 7
  • edited March 26, 2024
    Upgraded to Z7 and the results are in.

    FoxNews still does not retrieve a single snapshot.

    TimesMachine works fairly well, except the URL is still not working. I am disappointed to hear about the abstracts for it, however. Is there something I can do to help?

    The broken URL: http://timesmachine.nytimes.comhttp://timesmachine.content-tagging.us-east-1-01.prd.dvsp.nyt.net/timesmachine/1940/06/22/issue.html

    It should be: https://timesmachine.nytimes.com/timesmachine/1940/06/22/113093679.html?pageNumber=2

    The odd thing about the URL is that it is only http, when it is actually https.

    I'm aware that you said earlier you can fix that and thank you, if you can.

    As for the NYT articles, snapshots are inconsistent. Some pages download a snapshot while others do not. I cannot discern what will or will not work. Here are my examples:

    This article worked: https://www.nytimes.com/2024/03/22/arts/design/sothebys-auction-clients-nazi-loot.html

    This article did not work: https://www.nytimes.com/interactive/2024/03/23/world/europe/moscow-concert-hall-attack-map.html

    Many MANY thanks for all that you are doing. You are very much appreciated!
  • The Timesmachine fix simply isn't available yet. The abstract should work, too, once that's live.

    I get a snapshot on Foxnews ( https://www.foxnews.com/lifestyle/rare-elephant-twins-born-new-york-surprise-zoo-staff-sheer-improbability e.g.)
    and both NY Times pages you link to.
    Which browser? Have you tried with all other add-ons (in the browser) disabled?

  • Pushed @adamsmith's fix for the TimesMachine issues. Your Zotero Connector should auto-update within 24 hours, or you can update manually by clicking Update Translators in the Advanced pane of the Zotero Connector preferences.

    Re snapshot problems, open Zotero's preferences, go to the General section, and make sure "Automatically take snapshots when creating items from web pages" is checked.
  • (They say snapshots are working on all other pages and are sometimes working for NYT, so I don't think it's the pref -- I also did ask about that)
  • Thanks, missed that!
Sign In or Register to comment.