Google Docs plugin always detects my previous citations

[Split from Z. in google docs not working]

Operating Macbook everything updated, Z. + plugins for Safari, Chrome and FF today.

In when I ask for new citation (expecting empty white line in the red bar, Z always detects my previous citations, no matter what is deleted or edited. This is rather frustrating.
  • This just sounds like you haven't closed the citation dialog. If the citation dialog is open, clicking Add/Edit Citation would just bring it to the front.

    Press Esc to close the citation dialog and try again.

    If you're still having trouble, provide a Debug ID for reproducing this after restarting Zotero.
  • Thank you for your assistance but this happens also after fresh restart or forced shutdown of Z.
  • Yes, there was another report of this, so this may be a regression in the latest version.

    But can you provide the Debug ID, then?
  • 820111979

    This is the ID I get. I'm not 100% familiar with what to do with that number though ;)
  • Can you reproduce this in a new document? If not, can you use the last step in the Troubleshooting Errors in Word Processor Documents to identify what is causing it in your document? If you can, does it happen on all browser? Do any of these browser have addons installed that could interfere with Zotero on Google Docs?
  • Still exists.
    Without trying the Troubleshooting option I simply created new/fresh document in Z.
    Did put in a one citation into that fresh doc. Than wanted to add second citation in the latest line of the document and Z only comes up with the first citation and acts like I want to edit that one.

    This is the on Safari, FF and Chrome.
    FF is freshly installed on my MAC and has NO add-ons or anything.
  • If you select some text by dragging your mouse over it, then put the cursor at the end of the document, and attempt to cite, does it create a new citation?
  • Nobe. Still in the fresh new document but Z only wants to edit my previous citation.

    I even erased the only citation in the document and tried to add new one.
    The red bar in Z comes up with the editing mode as shown above if I place enter then Z freezes. It's like Z does not let go of the latest citation you put into the document
  • You have to close the citation dialog before doing this. Either press Enter or Escape in the citation dialog, then try select some other part of the document, then select at the end of the doc and attempt to insert the citation.
  • I came to the forum to post about this same issue, but then saw this existing thread.

    I've replicated the same problem as @erlingurg10 in this document:

    The steps to replicate are:
    - Place cursor at some location in the document.
    - Insert citation (using keyboard shortcut, if that matters).
    - Select item from library using citation dialog.
    - Press Enter to close citation dialog.
    - Wait for citation to complete inserting and for citation dialog to close.
    - Place cursor at a different location in the document (neither within nor adjacent to the just-inserted citation).
    - Insert citation (again, using keyboard shortcut).

    The resultant error is:
    - When the citation dialog appears, it will be populated with whatever item was selected for the first citation.
    - Select a different item in the citation dialog, and that item will replace whatever was in the first citation.
    - No second citation is added at the cursor's current location.
    Unlike @erlingurg10, though, if I delete the first citation, I can add a new citation with .

    As @adomasven suggests, I've confirmed that the citation dialog is closed before attempting to insert a new citation.

    I've submitted the debug output as D1475453309.

    MacOS 10.15.7
    Chrome Version 121.0.6167.139
    Zotero 6.0.13
    Zotero Connector 5.0.122
  • @epsb If you insert a citation, then move the cursor in google docs by selecting some text, and attempt to insert a citation, do you still get the dialog for the original citation or not?
  • What I did was:

    Placed new/first citation in the fresh document
    The citation dialogue comes up I find my citation + return and the citation is in place and the document is ready for more writing.

    Next thing I try is to place the cursor in the second line, after writing some more text, insert another citation (use either shortcut or menu bar) and citation dialogue pops up with the first citation. If I place then return nothing changes, if I add citation behind the first one in the dialogue to the one thats already in the dialogue the new one only adds as second citation with the first one. Nothing happens where the cursor is placed totally at different place in the document. Z is always fixed on this first citation.
  • There are two approaches I tried.

    First approach:
    - Type some text.
    - Add a first citation.
    - Select some other text in the document.
    - Click to place the cursor at another place in the document.
    - Add a second citation.
    This results in the second citation not being added but instead altering the first.

    Second approach:
    - Type some text.
    - Add a first citation.
    - Select some other text in the document.
    - While __leaving that text selected__, add a second citation (@erlingurg10, leaving the text selected may be the detail for you to try).
    This results in a new citation being inserted where the selected text is. Even if the selected text is a single character (a period, a space, etc.), it seems to add a new citation.

    After that, inserting a citation without having any text selected sometimes goes back to the first citation, but sometimes it inserts a new citation. Not sure what's going on, but I've submitted Debug ID D2070459247, in case you want to take a look.

    At any rate, seems like selecting some text before inserting a new citation provides a work around for now, but presumably this is something the development team should investigate further.
  • thank you epsb for this. Seems like the same issue.
    I'll watch those two threads. Meanwhile I'll just manually write in my citations and keep on with writing and hoping this will be solved some day ;)
  • edited March 21, 2024
    @erlingurg10 @epsb would you try the Zotero Connector Beta for Firefox and see if it works correctly for you with it? Make sure to check if inserting new citations and editing existing ones works as expected.
  • The beta connector is very slow but works as expected.

    Thank you for this.
  • What do you mean by very slow? What takes a lot of time? Is it the same in the new document? When was it faster?
  • Placing new citation I found to be slower than before.
    Specially after the citation has been put into the citation dialog and you wait for the document to update to continue to write.

    There might have been other reasons for that delay, when trying now while I'm writing this things seems to be working like they did.

    I'm operating new Macbook AIR with and the FF browser.
  • As of this morning, the highlight-and-insert work around was no longer working.

    As @adomasven suggested, I installed the Firefox connector. Thus far, it works as expected.

    I suppose the work around for now, then, is Firefox?
  • We've submitted Zotero Connector 5.0.123 with this fix for Chrome and Edge. It'll be available as soon as Google and Microsoft approve the updates, usually within a day.

    We've also released 5.0.123 as a release version for Firefox.
  • I have noticed that placing a new citation has become slower than before, especially after entering the citation into the dialog box. It takes some time for the document to update before I can continue to write. However, upon attempting it again while writing this, everything seems to be working as it did before.

    I am using a new MacBook Air with the Firefox browser.
  • By "some time" do you mean a matter of a couple of seconds, or a more significant amount of time?
Sign In or Register to comment.