Visual Basic error following Microsoft Word update March 12 2024 

My Zotero has worked beautifully the least 6 months but has now stopped working after Word was updated following a March 12 office update. Whenever trying to ‘Add citation’ using the Zotero plugin in word I am met with the following error message:

“Zotero could not perform this action. Please ensure that a document is open. If you have performed a custom installation of Office, you may need to run the installer again, ensuring that "Visual Basic for Applications" is selected.”

I have tried everything I could think of following these :

However, no luck with re-intstalling Office 365 and Zotero either :(

Even when opening a blank document and trying to insert a citation to that it is the same.
Are there anything I am missing here or are there any known incompatibility issues going on here?
All help is very much appreciated as my PhD thesis is due in 3 weeks.

I am Using
Word: Version 16.83 running on an institutional license.
macOS Sonoma v 14.2.1 on an Apple M1
Zotero 6.0.35
  • edited March 18, 2024
    There isn't a general incompatibility with 16.83, although Zotero users occasionally report what you are experiencing after any Word updates. You should start by restarting your computer. For some users it helps to fully remove Microsoft Office and reinstall it again. If that doesn't help, you can try creating a new macOS user account and see if it works there. If it does, it indicates some issue with your current user configuration, either Word or somewhere else in the OS.
  • I encountered the same problem as you. I cancelled 'Use Rosetta' to open Word, and then everything returned to normal!
  • I'm getting the same error as of this morning, please help, I've tried everything!
  • @wikam33 did you try disabling Rosetta to open Word (in /Applications right-click Microsoft Word -> Get Info and uncheck "Open using Rosetta", then restart Word). Did you try creating a new macOS user account?
  • Yes it worked on a different macOS account but I needed it to work on my main one without transferring all my files. Cancelling Rosetta works now though, thank you!
  • Disabling Rosetta in Word seems to have done the trick for me as well! Thanks so much for the suggestion!
  • OMG thank you @psychpan!!!!!! You saved my life for this.
  • edited March 19, 2024
    We've just rolled out Zotero 6.0.37 for Mac with a clearer message when this occurs that suggests checking whether Word is running under Rosetta.

    Thanks to @psychpan for identifying the problem!
  • Thanks everyone, this did the trick for me. I am on the latest stable public MacOS release and on the latest Zotero 7 Beta. Not sure why Word thought it had to use Rosetta again (or rather, why MacOS reset the box) because I always ran it natively.

    @dstillman: I am sure you have changed the error message in the next Zotero 7 build, too, though not released yet. THanks so much for your great work.
Sign In or Register to comment.