I just updated to the latest version and got the following error:

Component returned failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED) [nsIFile.lastModifiedTime]

I logged in to both the zotero website and the webdav server, and both are working fine. This may be related to a previous problem I had with weird modified dates on some files (such as 1970 or 2030).
  • Provide a Report ID.

    If you have any anti-virus or other security software, try disabling it.
  • Hm, the following happened: after the error, I tried to sync again. The error now was "sync still in progress". Intrigued, I restarted firefox, synced again, and Zotero decided to re-upload all my files back to the server. It did that, and then everything was fine. Nothing bad seems to have happened, since this computer has the most recent version of all files anyway. Since the error is gone, I cannot provide a report ID now. However it may still happen to other users who aren't so persistent in re-syncing and restarting firefox in this specific order... I wish I had gotten the error report before fiddling with it further.
  • Ok... I changed my webdav server password in the meanwhile, it seems that it was that action that triggered the re-uploading of the whole library, because now I changed the password back and it's re-uploading again.

    So: The problem didn't correct itself, rather re-uploading the whole library seems to have corrected it by accident. The fact that changing the webdav server password can trigger this response is a bit puzzling.
  • Hi, I had the same problem, but it seems to be related to my antivirus & firewall suite (Kaspersky Internet Security Suite 2010). When I disabled the suite, the sync worked fine. Has anyone any idea how I can set Kaspersky to work with Zotero?
    Many thanks for the help!
Sign In or Register to comment.