The download option on the Zotero website is basically unavailable

This discussion was created from comments split from: Zotero Plugin stopped working in Firefox.
  • I have the same problem and the download option on the Zotero website is basically unavailable - I have been clicking on it day in and day out but it is always stuck...
  • edited 28 days ago
    Same answer, particularly #14, if nothing through #1 to #13 worked

    (I may be off-topic. Feel free to delete if it's the case)
  • I think @elettra77 may be talking about something unrelated. @elettra77, can you explain exactly what you mean here, and/or provide a screenshot? I'm not sure what "download option" you're referring to.
  • Definitely works in general. have you tried with a different browser? And do you see any error message at all or does nothing happen? Is this your personal computer/network of a company/institutional one?
  • It's my personal computer and I have tried with Edge and it's the same, and no, there is no error message popping up, there's just an endless wait...but well, I guess that if it does work for you then the problem is somewhere in my laptop/connection...
  • This sounds like security software on your computer blocking the download of certain files (of which, executable files like installers would certainly be likely to get included). You might try temporarily disabling security software, or its browser/internet functions.
  • Thank you @fcheslack, I will do so!
Sign In or Register to comment.