Plugin for Mac Word 2004 yields Run-time error 5

I just upgraded to the latest Firefox, the latest Zotero and the latest Zotero plugin for Word 2004 for Mac. In trying to install the plugin it kept asking me to "select the Word Script Menu Items folder"--but there is no such folder. Unsure what to do, I tried choosing MS Office|Startup|Word but now when I try to use the Zotero plugin I get:

"Run-time error '5' Invalid procedure call or argument."

Can anyone help? I really depend on Zotero and need to get this plugin working again. Thanks!
  • edited February 19, 2010
    The "Word Script Menu Items" message shouldn't appear for Word 2004, but it seems to on some systems. (Is this a non-English system? Do you have or have you ever had Word 2008 installed?)

    What full path do you mean by "MS Office|Startup|Word"? The Word 2004 template file ( should normally be installed into /Applications/Microsoft Office 2004/Office/Startup/Word. Remove all Zotero files from those directories, restart Word to make sure the Zotero toolbar is gone completely, and reinstall the plugin using Reinstall Word Components.
  • Dan, thanks for that. I did as you suggested, trashing, closing Word, reinstalling plugin etc. When I then open Word, type a sentence and click the citation button on the Zotero toolbar, I get the same MS Visual Basic runtime error. is installed in /applications/microsoft office 2004/office/startup/word. Also there is a folder called Zotero with several other files.

    By the way, this is an English language system and I have never had Word 2008 installed, although I may soon.
  • It probably won't help, but delete the Zotero folder in Startup/Word—those script files are for Word 2008 and don't belong in that directory anyway.

    Do you get this in a new document, or only an existing one? If the latter, see Debugging Broken Documents.
  • You are correct. I deleted the Zotero folder in Startup/Word and it made no difference.

    So far I am having the problem in new documents. I do not have the nerve to open up my book manuscript (finished, only working on revisions right now) and mess with it. I don't believe I have any other documents with Zotero footnotes; if you want to send me one I can give you an email address, or perhaps there is one associated with this account and you can access that.

    Again, thanks very much for your help.
  • By the way I have just ordered MS Office 2008 for Mac, so if that will solve the problem I will be happy.
  • Ok, I installed MS Office 2008 and keep getting a "cannot communicate with Firefox" error, which I also mentioned in the thread devoted to this at:

    Zotero is a great product on which I am now dependent and it would be great to get this going again as I work to finish my book. Many thanks to the support staff for any help.
  • Is your computer set up to log in over a network? If so, look here; the dev builds (linked from that page) fix the issue, and a stable fix should be out in the next week. If you aren't logging in over a network, with Firefox running, try opening Terminal (in /Applications/Utilities) and typing

    ls -la ~/.zoteroIntegrationPipe
    Let us know what the output is.
  • Simon, thanks, and sorry for my delay in acting on this. I did as you suggested in Terminal and got:

    ls: /Users/Dan/.zoteroIntegrationPipe: No such file or directory

    PS--Is there any way to have the Zotero forums send email when one of my participated discussions has a new posting?
  • Sigh. Now (using Word 2008 for Mac) when I try to add a citation the plugin launches nicely, asks me what style I want to use, lets me add the citation--and then begins a never-ending cycle of mad repagination of my 95,000 word manuscript. When I finally quit word Zotero says it couldn't complete my citation due to some error, the nature of which I suppose I should have written down. Anyway this happened before I installed the latest version of the Zotero plugin, and again after doing so.

    Thanks for any help.
  • I kind of had the same problem as Simon. I just switched from PC to Mac(OSx) and uploaded my whole library into Zotero. I am using Word2004 (french version) and I can't see the toolbar (of course i checked but it does't appear in views->toolbar).
    The file correctly installs in /Applications/Microsoft Office 2004/Office/Startup/Word
    I followed the step indicated in support for plugin trouble. When I erase it and install it again it keeps asking "select the Word Script Menu Items folder". I also I got this Zotero folder that you say is for Word2008
    If i clik on the file (when located in /Applications/Microsoft Office 2004/Office/Startup/Word) it asks me if i accept the macros, then a blank word document appears WITH the zotero toolbar but innoperative and disapears as soon as I open another document.
    Is there a problem with the macro or something? I don't get it i spent severall hours trying to install the plugin everywhere it's possible but it still not work...
    As a graduate student i am also now really dependent on Zotero and i can't work without this tool. I don't have the possibility to switch for word 2008.
  • edited March 23, 2010
    kharga: You don't use the plugin by double-clicking the template. You just open Word.

    Does appear in Tools->Templates and Add-ins? (The troubleshooting page incorrectly said this was only for Word for Windows, but it's for Word 2004 as well.)

    Did you follow the instructions for instructions for non-English users?
  • Yes appears in Tools-> Templates, only if I add it, I can do it with 2 different buttons : "link" a document template or below "add" a global document template. And the Zotero toolbox appears... but does'nt work...and I don't get any kind of error message.
    Finally, is /Applications/Microsoft Office 2004/Office/Startup/Word (it's the same name in french version of office) the correct location for
  • kharga: Don't do anything manually with the .dot—you don't need to open, "link", or "add" it. It just needs to be in the startup directory, and then it should appear in Templates and Add-ins. If it's not enabled (with a checkmark) for some reason, enable it.
    Finally, is /Applications/Microsoft Office 2004/Office/Startup/Word (it's the same name in french version of office) the correct location for
    If that's what it says in Templates and Add-ins, it should be. If appears in Templates and Add-ins when you start Word, then it's being detected.

    If the toolbar buttons then don't actually doing anything, that's a separate issue. I'm not clear on what you've done so far, but just to make sure you're using the right version, delete the file from the startup directory, restart Word to make sure all traces are gone, and then close Word and do Reinstall Word Components.

    In any case, if you have further problems then start a new thread, since you took over scribbler's thread with a mostly unrelated issue.
  • Ok, so I just installed the very latest upgrade to the Word plugin, restarted Word, and gave Zotero another whirl. The good news is that, in a fresh Word for Mac 2008 document containing a single sentence, I was able to add an endnote from my large database with no problems. This was great.

    But then I opened my book manuscript (a 95,000 .docx file) and attempted to add an endnote there. All seemed to go well at first until Word embarked on some kind of frenzied activity I might best describe as a conversion experience. The messages it flashed at me went by so fast they were practically subliminal, but I could make out the words "Word is converting", with some kind of progress bar underneath. This went on quite awhile, and when I finally decided to close Word I got an error message.

    Is this file just too big for Zotero? Might it be corrupt somehow? Is anybody else having such troubles? I would really like to get this straightened out, so thanks in advance for any help.
  • Have you tried simply letting the conversion go while you'll be away from your computer for a while?
  • If you're using print layout mode, you might also be able to speed things up by switching to draft mode (View->Draft) before upgrading the document.
  • Ok, switching to Draft mode and then going off for a cup of tea seemed to work. After that adding citations seems to be reasonably fast, and I haven't yet had any more Word crashes, which for awhile seemed endemic to the plugin. So thanks for that suggestion.

    Unfortunately, whole swaths of citations are now missing! The footnote is there in the text but it leads to nothing in the endnotes, and there is no tooltip either when I pass the cursor over the number. So those are gone, whether in draft or print view. I'm pretty sure i can reconstruct them but now I'm worried about all the footnotes, rather like the test-taker who skips one answer and gets them all out of sequence. I would urge caution on any users upgrading with a major work in progress. Zotero has issued a similar warning but I reached the point where I had little choice. I will post again after a bit to update on my experiences, for those in a similar spot. Believe me, this is a headache you don't need.
Sign In or Register to comment.