Zotero (6.0.35, Mac) crashes when opening snapshot

edited March 7, 2024
ReportID: 1141302928

When I open a snapshot, the snapshot opens in my browser (Safari) but Zotero (Mac, 6.0.35) crashes. I have tried it with different snapshots, created on different days. It happens with all of them.
(Question: was the report ID helpful -- I did not see any crash-related notes in there...)

Steps to reproduce:
1. Open Zotero
2. Open item with snapshot
3. Double-click on snapshot

Here are the first 100 lines of the Console Error Report:
Translated Report (Full Report Below)

Process: zotero [1697]
Path: /Applications/Zotero.app/Contents/MacOS/zotero
Identifier: org.zotero.zotero
Version: 6.0.35 (6.0.35)
Code Type: X86-64 (Translated)
Parent Process: launchd [1]
User ID: 501

Date/Time: 2024-03-06 11:28:05.3980 +0100
OS Version: macOS 14.3.1 (23D60)
Report Version: 12
Anonymous UUID: 4B9A9B5C-00D9-2C71-2CE2-39C1F0F4E746

Sleep/Wake UUID: 2C636E71-235B-4638-B1A5-D108245978F3

Time Awake Since Boot: 2200 seconds
Time Since Wake: 2188 seconds

System Integrity Protection: enabled

PC register does not match crashing frame (0x0 vs 0x7FF819CA6BE7)

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Codes: KERN_PROTECTION_FAILURE at 0x00000003080b0ff8
Exception Codes: 0x0000000000000002, 0x00000003080b0ff8

Termination Reason: Namespace SIGNAL, Code 11 Segmentation fault: 11
Terminating Process: exc handler [1697]

VM Region Info: 0x3080b0ff8 is in 0x3048ad000-0x3080b1000; bytes after start: 58736632 bytes before end: 7
unused __TEXT 202553000-202555000 [ 8K] r--/r-- SM=NUL ...ed lib __TEXT
GAP OF 0x102358000 BYTES
---> Stack Guard 3048ad000-3080b1000 [ 56.0M] ---/rwx SM=NUL
Stack 3080b1000-3088ad000 [ 8176K] rw-/rwx SM=SHM

Error Formulating Crash Report:
PC register does not match crashing frame (0x0 vs 0x7FF819CA6BE7)

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 libsystem_pthread.dylib 0x7ff819ca6be7 ___chkstk_darwin + 55
1 CoreFoundation 0x7ff819d0fb37 __chkstk_darwin + 23
2 CoreFoundation 0x7ff819e5fa6d _CFStringCreateWithFormatAndArgumentsReturningMetadata + 169
3 CoreFoundation 0x7ff819d355ee _CFStringCreateWithFormatAndArgumentsAux2 + 28
4 Foundation 0x7ff81ac31c41 -[NSPlaceholderString initWithFormat:locale:arguments:] + 188
5 Foundation 0x7ff81ac3f13b +[NSString stringWithFormat:] + 153
6 Foundation 0x7ff81acc3ef6 NSStringFromRect + 81
7 AppKit 0x7ff81d343501 -[NSWindow _setFrameCommon:display:fromServer:] + 135
8 XUL 0x1137c4026 0x1117a9000 + 33665062
9 ??? 0x6c707369643a ???

[additional output removed — D.S.]
  • 1) Are you using multiple monitors?

    2) Does it happen if you disable all plugins?
  • thank you, dstillman!

    1) Yes. I tried the same with only one monitor: no crash. With a second monitor: crash.

    2) With a second monitor attached, I disabled all plugins, and it did not crash.

    3) I have enabled plugins one by one, and Zotero Tag 0.3.0 seems to be the culprit: https://github.com/windingwind/zotero-actions-tags#readme

    To be sure that it is not the interaction of several plugins, I checked the following, always with two monitors:
    - Zotero crashes when all plugins are enabled (including Zotero Tag)
    - Zotero crashes when *only* Zotero Tag is enabled (and all others are disabled).
    - Zotero does *not* crash when Zotero Tag is *dis*-abled but all other plugins are enabled
  • edited March 7, 2024
    There's a known bug in the Mac version of Zotero 6 where plugins that open a progress window can trigger a crash when external monitors are used. That is fixed in the Zotero 7 beta.
  • Good to know, thank you!
Sign In or Register to comment.