Zotero connector not saving proxy settings

My institution recently changed from EZproxy to OpenAthens which means I had to delete the old proxy settings in the Zotero Connector and enter new settings. The connector is not saving the new settings. I click '+' to add a proxy and enter the Login url details. There is no save button to confirm the change. After closing the connector tab and then reopening, the information has not saved. This is happening across two computers and two different browsers, and after reinstalling the connector. How can I fix this?
  • You have to enter a valid Login URL and Proxied URL scheme for it to be saved. If you leave one of those two fields unchanged the proxy will not be saved.
  • Thanks. The advice from the library is to enter the following settings:
    Automatically associate new hosts - leave unchecked
    Login URL scheme - use the scheme they have provided
    Proxy URL scheme - leave blank
    This still results in the settings not being saved.
  • Yes, you cannot leave the proxy URL scheme blank. Zotero proxy support cannot work without the proxy URL scheme. Although I'm not sure if OpenAthens even has an URL scheme, and in that case you don't need to setup Zotero proxy entries at all. When you visit a journal page via the OpenAthens proxy, what URL are you seeing?
  • This is the advice from my institution about OpenAthens including Zotero settings details: https://rmit.libguides.com/openathens#s-lg-box-22644004

    When visiting a journal website I see the plain website, not the EZproxy version (as that is now deleted).
  • Those instructions are incorrect, you should let the administrators of that guide know.
  • Thanks. Where can I get correct instructions for OpenAthens and Zotero integration?
  • edited March 1, 2024
    My institution switched from EZproxy to OpenAthens a few years back. The instructions from my institution for Zotero are to either uncheck Enable Proxy Redirection, or just remove any old EZproxy and university URL entries from the Configured Proxies box. I have the second setup (ie empty Configured Proxies box). Whether there are other ways that an institution can implement OpenAthens that might require a different configuration ... I don't know.
Sign In or Register to comment.