Import problems

edited February 27, 2024
Running into a few problems with import.
have Z6(mac) and Z7 beta (windows) running on different devices, and I've duplicated the problem for both.

different problems, but maybe both are related to parsing issues? sorry not a technical person, so that speculation might be wrong.

1. so for nbib, I ran a search on pubmed, --> 'send to' --> citation manager --> nbib file (with ten items selected) --> import to zotero gives only one item added.

2. For RIS, it's even worse. from anystyle (and the older hubmed citation finder):

export as RIS --> import to zotero --> all items show up, but completely mangled because the hyphen (which I think is part of the RIS syntax) is instead read as part of the item, and therefore it doesn't really give a useful entry for the items.

I just got the same issue with the zotero metadata importer in calibre. was hoping to use that to take advantage of zotero's phenomenal PDF reader.

I'm sure I've been able to do this without problems in the past, so I think these may be new problems?

if I've been doing something wrong or if this is a problem outside of zotero, would be grateful for suggestions on solutions as well.

edit: for clarity
  • Have you looked at the nbib file in a text editor? Are there actually 10 items in there?
    If so, could you post it to and link to here?
  • hadn't. have now. there are 10 items.
  • That imports 10 items for me. Reset your translators from the Advanced → Files and Folders section of the Zotero settings.
  • thank you!
    that solved both my problems.

    could it be something I did that caused this change in behaviour in the first place?
  • If you have plugins, probably a plugin.

    Otherwise could be something with your data directory, particularly if you have your data directory in a cloud storage folder or on an external drive.
  • I have both, unfortunately.

    The only plugins I have are attanger (the zotfile replacement) and the betternotes plugin. if you think I should raise it on their github I will.

    is there a way to narrow it down without systematically shutting things down? don't need to because you've shown me what to do before I import, and import is a rare sort of thing anyway. but I'd like to know. in case I should expect other misbehaviour as well.

  • We'd need a Debug ID while you can reproduce it. If it's working now, nothing to do.
  • one more copy of zotero on another device. so it can be arranged. :-)
Sign In or Register to comment.