Problem syncing changes to notes

I use the same Zotero account at my office and at my house. Recently there was an internet outage at my house. I made some edits to some of the same notes from both my locations, but the changes didn't sink up until the internet came back on at my house. The resulting situation was such that both the "local version" and the "remote version" of some of my notes contained new data. A manual sync was triggered. But in most cases the proposed "merged" version left out data from either the remote or the local version -- it seemed only able to choose one or the other, rather than actually merging.

Is this a known issue?
  • Conflict resolution in Zotero doesn't merge individual lines in notes—it just lets you choose one version or the other.
  • But the editable third pane exists so that you can copy and paste from one version or the other to combine parts of both.
  • Okay, I tried that, but for me the third pane did not seem to be editable. I'll try again next time this happens.
  • I just tried it again on my Mac (the same manual sync keeps re-running, since it can't complete due to the sync issue I reported separately). Anyway, none of the panes are editable.
  • Actually, it looks like editing of the merge pane isn't implemented for notes due to an unresolved bug. (The third pane is editable for regular item metadata.) This shouldn't be a big deal, though, as conflicts should be very rare if you're using auto-sync. Just pick one side, copy the other side to the clipboard, and merge in any changes in the note editor after syncing.
Sign In or Register to comment.