Zotero isnt working after "add citation" only red bar


After I try to add citation red bar without progress line pops out and just stays there indefinitely. I tried restarting and reinstalling Zotero, but it doesn't help :(

ID D558848509
  • I'm having the same issue with the latest version of zotero extension for Google Docs on both Chrome and Edge browsers.
  • edited February 24, 2024
    This is yet another problem stemming from the Google Docs UI changes they've been testing with a small number of users.

    We've pushed out a beta of the Zotero Connector for Firefox, which we're hoping will fix this. If you're seeing this and are able to test in Firefox, please try that and let us know.

    Update: A fix is now available in Zotero Connector 5.0.118 for Chrome, Firefox, and Safari.

    Update 2: We've made some additional fixes in Zotero Connector 5.0.119.
  • Note that you might need to restart Zotero and refresh the Google Docs tab after installing the Zotero Connector beta.
  • It works with the beta in Firefox! Thanks!
  • I confirm, the beta works with Firefox. Thanks a lot!
  • Great, thanks. We've released Zotero Connector 5.0.118 for Firefox with this fix, and we'll submit versions for Chrome and Edge, which should be out within a day.
  • edited February 22, 2024
    Just as an update for the folks posting here saying it's not working, nothing has changed since my previous comment: we've submitted Zotero Connector 5.0.118 for Chrome and Edge with a fix for this issue, and they'll be available once Google and Microsoft approve them. You can use Firefox now to get a working version.

    We're able to release updates for Firefox immediately, but updates for Chrome and Edge need to be approved, and we have no control over how long that takes, though it's usually less than 24 hours.

    We'll post here when 5.0.118 is available for Chrome and Edge. You can check the version you have at any time from the Extensions pane in your browser.
  • We've released Zotero 6.0.32 for Mac with Zotero Connector 5.0.118 for Safari, which contains this fix.

    If you're on a Mac, you're waiting for the Chrome update, and you don't want to install Firefox, that would be an option. You can enable the Zotero Connector from the Extensions pane of the Safari settings (Safari menu → Settings… → Extensions tab).
  • thank you so much. In the meantime, I will switch to Firefox. It works fine there
  • edited February 22, 2024
    Zotero Connector 5.0.118 for Chrome has been approved and is now available with this fix. You can check your version and force an immediate update from the Extensions pane in Chrome (Window → Extensions).

    You may need to restart Zotero and reload your Google Docs tab after updating.
  • I have tried it, and it works now.

    Thank you so very much. You have no idea how many scholars you have helped today.

    Much appreciated.
  • edited February 22, 2024
    We've gotten a few reports of continued problems with 5.0.118, including a recurrence of the previous problem of citations not being inserted into the document.

    We've made some additional fixes in the Zotero Connector beta for Firefox (5.0.119b1) Zotero Connector 5.0.119 for Firefox. If you're still having trouble, please try that in Firefox and let us know if it fixes the problems for you.

    Sorry for all the trouble here. Google has been testing some subtle, undocumented changes to how Google Docs works, and we mostly haven't been able to reproduce these problems ourselves, so we've been trying to fix things based on feedback here while preserving compatibility with the version that most people still have.
  • The beta for firefox helps and works! The process is still very slow, though.

    Thanks for your effort. I've been following the discussion for a few days now and truly see that you are giving your best! Thanks.
  • edited February 22, 2024
    We've now released Zotero Connector 5.0.119 for Firefox. We're going to hold off on submitting updates for Chrome and Edge until we get more feedback on whether this actually fixes the issue, so if you're still having trouble and are able to test in Firefox, please let us know if 5.0.119 fixes things for you.
  • Can confirm that 5.0.119 for Firefox fixes this issue. Thanks for the speedy resolution.
  • edited February 24, 2024
    Zotero Connector 5.0.119 is now available for Edge as well. The Chrome version will be available as soon as Google approves it, and we'll release Zotero 6.0.33 with an update for Safari soon.
  • Zotero Connector 5.0.119 is now available for Chrome, and we've released Zotero 6.0.33 for Mac with an update for Safari.
  • I can certainly confirm the Firefox update fixed the issue on my end. I am Mac user. While I haven't tested the newly launched Chrome update, I can confirm that it was impossible for the past few days to make it work on my Mac and my office PC.

  • Chrome is not working for me
  • @marissakach: Make sure you’re running Zotero Connector 5.0.119, and then restart Zotero and reload Google Docs.
  • Just tested the new connector with google chrome, google docs on mac, now everything works perfectly :). No hang ups or issues.
Sign In or Register to comment.