Zotero in Google Docs not inputting any citations

Hello! Here is the debug ID for my problem: D1898987725

Randomly today, my google docs zotero integration stopped working. I am able to click "add/edit citation", I get transferred to my Zotero, I can type in the citation I am looking to input, but then the area where it SHOULD be in Google Docs is blank. The same thing happens if I try to insert a bibliography.

I have tried restarting Zotero, Google Chrome, Google docs, and my computer. I have logged in and out of my Zotero and Google suite. When I try things out in Word, there does not seem to be a problem, so I would assume that this is a google integration issue. Can anyone help?
  • We've gotten a bunch of reports of this. We're investigating, but we haven't yet been able to reproduce it ourselves.

    Can you provide a Debug ID from the Zotero Connector (rather than Zotero) for trying to insert a citation and having it not appear?
  • @dstillman thank you for your quick response! I just tried it again tonight, and its still not working. The Debug ID is: D1123544903

    Thanks for your help in fixing this! Fingers crossed things get sorted out soon :)
  • edited February 20, 2024
    OK, we believe this is fixed in the latest Zotero Connector beta for Firefox. For people seeing this who are able to test in Firefox, please install that, reload Google Docs, and let us know if it fixes the problem for you.

    (We believe this could happen intermittently to the same people who were seeing the previous Google Docs problem, caused by some UI updates that Google is testing. In this case, the document size and/or your distance to Google servers might affect whether it happens.)
  • We've gone ahead and released Zotero Connector 5.0.117 for Firefox, which we believe will fix this issue.

    We've also submitted 5.0.117 to the Chrome and Edge extension stores, so it will be available as soon as it's approved by Google and Microsoft.

    Please let us know if the problem is fixed for you after trying 5.0.117.
  • @dstillman I was able to get Zotero to work in Firefox!! Thank you so much!
  • Zotero Connector 5.0.117 is now also available for Edge. Still waiting for Chrome.
  • Zotero Connector 5.0.117 appears to have fixed the issue in my Google Chrome version (121.0.6167.184), too.
  • Yes, Zotero Connector 5.0.117 is now available for Chrome.

    5.0.117 is also available for Safari in the Zotero 7 beta. We'll push out a new Zotero 6 Mac build with this fix within the next couple days.
  • We've gotten some additional reports of this problem reoccurring with Zotero Connector 5.0.118 (which fixed a separate problem of the progress bar hanging).

    We may have a more robust fix for this in the Zotero Connector beta for Firefox:


    If you're seeing this in 5.0.118 and are able to test in Firefox, please try the beta and let us know there if it fixes the problem for you.
This discussion has been closed.