Google Docs: Citation doesn't appear but reference appears in bibliography

edited February 19, 2024
Thanks so much for fixing the pop up box issue, I'm not having that anymore which is great.

However, having managed to successfully add one citation and its related bibliography entry, now I can't add any more.

When I follow the process to add the citation in the text, no citation appears there, but the reference appears below in the bibliography. Then, when I tried a second time with a new article I wanted to cite, again no citation appeared in the text where I requested it, but it replaced the previous reference in the bibliography.

If I request add/edit bibliography, then it shows the Zotero pop up search bar, but solid red, no box to type in, then goes straight back to my document, with no way of adding a reference.

I've tried closing both Zotero and Google Docs and restarting multiple times, still the same issues. I'm using Chrome on a Macbook.

Hope this makes sense and you can help!
Many thanks,
  • Can you reproduce this in a new document? If so, what are the steps?
  • Hi - I just tried in a new document and I'm getting the first issue:

    In line of text > click on Zotero > select Add/edit citation > search for citation in Zotero pop up dialogue box > hit return after right citation in dialogue box > back to document but no citation in text.

    No bibliography links are possible as I get the message 'You must insert a citation before performing this operation'. And no bibliography references appear whilst trying to insert a citation like I described in my message.

    I just can't get it to work at all.

    Also - in the original document I tried yesterday, since I've been using Zotero the whole document glitches every few minutes and the cursor won't move. This has never happened to me in Google Docs before - only since trying to insert citations/bibliography with Zotero. I deleted the entries I described in my message but am still using Zotero for the bibliography in a manual way (right click on each text in my Zotero library > Create bibliography from item > Copy to clipboard > manually paste into my document). Have you heard of this happening before? I can't see any other reason for it apart from something to do with the integration.

  • This is happening to me as well! I keep trying to add a citation like normal in my Google Doc, but nothing pops up. I get all the way to the loading bar like normal, and then the space where I intended to put my in-text citation is blank.

    I have tried, to no avail:
    - quitting/refreshing Zotero, Google Chrome, my doc(s), my entire computer
    - logging out/in to both my Zotero and Google Chrome (which are linked)
    - inputting a citation in a different document

    This all started happening in the last hour or so. Maybe a brand new bug?
  • Yes, we've now gotten a bunch of reports of this. Let's continue this in the thread you opened, @daphnecondon, since that one most concisely explains the new problem.
Sign In or Register to comment.