Zotero 7 beta: Space in filename between the name and the extension

This discussion was created from comments split from: Available for beta testing: Zotero, redesigned.
  • It's faster and looks better. ++
    I am seeing a strange issue with renaming. There is always a space between the name and the extension. eg "iamafilename .pdf"
  • edited 11 days ago
    Did you customize the renaming format? Is there a space at the end? We should probably have that trim leading and trailing spaces automatically, but if you leave a space there, it will currently enter it, as you can see in the preview below the text box.
  • edited 11 days ago
    I have tried playing around with the string and have gone through many different versions. I have to think that it's something I'm doing but I can't put my finger on it. Here is what the string is currently:

    {{ firstCreator suffix=" - " }}{{ year suffix=" - " }}{{ title truncate="75" case="title" }}

    At first, I thought it might have been the truncation ending on a space, but I've tried many iterations of the truncation. I'm curious though, for long titles where a truncate value isn't expressed, the file name will be maxed out anyway, right?

  • edited 11 days ago
    Right, but is there a trailing space/newline character at the end of that in the text box? If you see a space before ".pdf" in the preview line at the bottmo, you just need to delete all whitespace after your format string and it should go away.

    Again, we'll fix this for a future version, but that's almost certainly the issue.
  • Oh, I see what you're saying. And yes, that is the issue. I didn't even realize it was there!
Sign In or Register to comment.