Zotero on new computer is unable to locate linked files

Hi. I recently shifted data to a new computer. I don't upload PDFs online, and like to link files on my computer to the Zotero bibliographies.
On my new computer, Zotero Standalone worked normally. Of course, it would not actually open any of the files since they are not stored on the new machine.
Now, I'm planning a complete shift to the new computer. I've gone ahead and copied the entire Zotero folder from my old computer and put in the relevant place on my new computer.
But the path still seems to be incorrect. When I try to open linked files, I just get a message "file not found" message. It says "The attached file could not be found at the following path."
How can I setup Zotero on my new computer so it reads relevant linked files from my new (and not old) computer?
  • Can you give an example of a full file path in the error message ?

  • Did you configured relavant path for linked files on Zotero instance on new computer? If yes, try to compare filepath on the old computer (open folder containing the file on old computer and see if you could find the file in the same place on new computer)
  • Here is an example of what I see when I try to open the linked file through Zotero on my new computer.
    /Users/HomeFolder/Documents/Downloaded Files/F2/F3/F.pdf
    (I am using HomeFolder, F2/3, and F as examples).
    I went back and checked and the only difference between this and the old computer is in the name of HomeFolder.
    In the old computer, it's named MyHomeFolder.
  • @danielborek.
    I am not sure how to do this. Perhaps this is what's causing the issue?
    It'd be great if I could easily reconfigure this and it solves the problem. Otherwise, it's going to take me ages to open each entry and relink the file stored on my computer :(
  • It's common to have linked PDF files at slightly different path locations on each computer. Zotero can deal with that easily by entering the parent folder location on a given computer under Linked Attachment Base Directory (Edit\Preferences\Advanced\Files&Folders). The LABD setting determines where Zotero *looks* for linked files. The LABD setting does not affect where any future linked files will get *stored*.

    It looks like your PDFs are stored several folder levels deeper than what would be the LABD on each computer (I am assuming that all your PDFs are not under ../F2/F3). Zotero is fine with that too. The LABD on the new computer should be:
    Users/HomeFolder/Documents/Downloaded Files
    (with root drive, back or forward slashes dependent on whether it's Windows, Mac, etc).

    If you are still using the old computer (otherwise you can forget about it*), you would set the LABD on it to:
    Users/MyHomeFolder/Documents/Downloaded Files

    *see 'Automatic Linked-File Relinking' at the above link.

  • @tim82. Thanks, this seems to have worked to an extent.
    I have now changed the base directory as you recommended.
    Now when I click on any file, it gives me a message saying the file in not at the location.
    It does, however, tell me that it has found "a file with the same name" within the "linked attachment base directory."
    I now have the option of clicking Link.
    The thing is I am kind of back to square one because I will still need to relink each and every entry in Zotero to the new location. That's going to be quite taxing.
    Any suggestions on how I can make this process automatic for all the Zotero entries in one go?
  • edited February 3, 2024
    The Zotero process is designed to work without the need to change any linked PDF file locations - and it almost always does. The error is telling you where Zotero thinks the linked file is. So that's the key to determining what's likely going wrong. How does (1) that error message location differ from (2) your Linked Attachment Base Directory setting on that computer, and (3) where the linked file actually is ? Can you list those 3 paths for a given linked PDF file that you try unsuccessfully to open in Zotero ?

    I assume you hadn't tried anything else earlier to solve the problem, that might now be throwing things off ... for example moving a linked PDF file (via your operating system) to another location ?

  • Thanks for your response tim820. So, I simply copied the files from my older computer to the new one.
    As I indicated above, the only change is in the name of the Home folder.
    To answer you questions above:
    (1) The only difference in the error message location has to do with a different name for the Home folder.
    It is looking for those linked files in the older folder. That folder exists only on my old computer.
    On the new computer it has a different name, so Zotero sees that as an issue and is unable to retrieve the file. Of course, the rest of the folder structure is the same in both computers.
    (2) I see from Zotero settings on my old computer that the base directory on the LABD is empty and a location is yet to be chosen.
    This was the same on my new computer. Except, after your earlier response I went ahead and put in the location manually.
    Please let me know if you have other questions. Thanks!
  • The fact that the error message is still referring to the folder on the old computer suggests that either (1) Zotero's conversion process from absolute to relative linked file paths (pointing them to the Linked Attachment Base Directory) has not occurred yet (did a Zotero message ask you if you wanted to do that ?*), or (2) the setting in the Linked Attachment Base Directory field on the new computer actually specifies the old computer's linked file folder.

    *Are you sure the message you mentioned about re-linking a single file for you was not offering to re-do *all* the links (point them to the LABD) ? Under Automatic Linked-File Relinking here it says that you should have got that message when you first tried to open a linked file on the new computer after setting the LABD ...

  • edited February 5, 2024
    Hi. Here is the text of the message (suitably anonymised):

    File Located Automatically

    The file could not be found at the specified location, but a file with the same name was found within your Linked Attachment Base Directory:

    Old Location: /Users/JohnWayne/Documents/Downloaded Files/SubFolder/Filename.pdf

    New Location: /Users/Johnhome/Documents/Downloaded Files/SubFolder/Filename.pdf

    Zotero can automatically relink this attachment.

    As far as I can tell, it is asking me to relink only the particular file I am trying to open, and not the entire directory.

    It looks like I'll just have to do this one by one :(
  • Did you actually click through that dialog? If there are others with the same path structure, it should offer to relink those next.
  • Hi. Thanks a lot for leading to me actually start the process of relinking.
    It has now worked and all looks good.
    It was a bit clumsy in the beginning, in that it first failed to relink, and then relinked only a few files.
    Eventually, I realised that it's relinking files in batches. So, I did have to go through several clicks but it would then detect an entire batch of associated files and relink them.
    It's saved the major part of that labour. Thanks!
Sign In or Register to comment.