This App Can't Run On Your PC- Windows 11

Hi, I have Windows 11, version 23H2. I am saving webpages from using my Zotero Chrome extension. The problem is I save things and I can open them several times. Then it stops working and gives me the message, This app can't run on your PC. To find a version for your PC, check with the software publisher. Any way to fix this?
  • edited January 16, 2024
    I am running the latest version of Zotero. I downloaded it yesterday. When the issue started I deleted the app and restarted my computer. I downloaded it again and the issue reoccurred. There are no error codes. It is just a blue box with the message.
  • What is it that you are trying to run/open when you get this error? Can you submit a Report ID? What is the full version number of Windows that you are running?
  • My version of windows is Windows 11 version 23H2 (OS Build 22631. 3007)

    When I try to report it as an error I get this message.

    "No errors have been logged since Zotero started.

    version => 6.0.30, platform => Win32, oscpu => Windows NT 10.0; WOW64, locale => en-US, appName => Zotero, appVersion => 6.0.30, extensions => Zotero LibreOffice Integration (6.0.4.SA.6.0.30, extension), Zotero Word for Windows Integration (6.0.3.SA.6.0.30, extension)"

    I can right click on the item, select view online, and open it when this problem occurs. But just clicking on the item causes the issue. I opened the program and all the links worked, but know some are displaying that message. I can open a few. I thought I fixed it earlier by deleting and redownloading them again. They worked for a few times and then the app won't work message appeared. Anything else you need please tell me.
  • The affected items are links to webpages on and I used zotero chrome extension to save these pages.
  • What happens if you right-click → Show File and double-click on the file from there?

    This sounds like a problem with whatever program is set to open HTML pages on your system. The message is from Windows and isn't referring to Zotero.
  • If I right-click → Show File and double-click on the file it gives the same message. I thought it was a windows problem since Zotero shows no errors. So changing the program which opens HTML files might fix it? I will try this and let you know if it doesn't work.
  • I tried the files before I changed my default browser. Two out of 13 worked with the double click. All of them worked with a right click ^ view online. I switched the default browser from Google Chrome Microsoft Edge. I had the same result. Could the files be corrupted by the browser?
  • Deleting and Redownloading the files has worked so far in Microsoft Edge. Thanks for your help.
Sign In or Register to comment.