Error connecting to WebDAV server

WebDAV sync to my Synology server recently stopped working when I accidentally changed some permissions for the user account Zotero uses to access the server; it will not start working again after returning permissions to their previous state, and I'm having trouble figuring out why.

Zotero Settings > Sync > File Syncing > Verify Server says "Server configuration verified - File sync is successfully set up." However when I try to sync, syncing churns for a minute before saying "[JavaScript Error: "Error connecting to server. Check your Internet connection."]".

WebDAV sync also stopped working on the iOS app at the verification step, saying "Could not connect to WebDAV server".

I can connect via WebDAV using the macOS Finder, but it gets stuck showing "Loading..." in the main pane of the Finder window.

I've tried updating and rebooting Zotero, macOS, and the server, all to no avail.

Could someone look at the debug log and glean some insight into what's happening?

Debug ID: D475669854
  • This doesn't have to do with WebDAV at all. A request to the Zotero servers is failing.

    Can you try the Zotero 7 beta and let us know if that fixes it for you? If not, we can try to fix it there.
  • Weird. My most recently-added Zotero items show up on ...
  • I get the same error in Zotero 7.
  • @dstillman What can I do to try to fix it?
  • We're working on a fix for this, but in your case a fix would just reveal another problem, which is that a ZotFile-created table-of-contents attachment note is way too long to sync.

    Paste 9REZT78I into the Zotero search bar in All Fields & Tags mode to find the attachment in question and clear the note in the right-hand pane. (You might have other notes that are similarly too long, though. Searching for id="toc" should show all ZotFile-created notes.)
  • That attachment note has been a problem for some time. I've had trouble clearing the content without crashing Zotero.
  • edited December 6, 2023
    You should just right-click → Show File, move the PDF to your desktop, delete the attachment item in Zotero, empty the trash, and drag the PDF back onto the parent item to create a new attachment item.
  • I ended up deleting the attachment file, disabling Zotfile's automatic TOC generation, and re-adding the attachment. Now the desktop app seems to work perfectly and I can see activity from Zotero on my server.

    The iOS app still won't connect to the WebDAV server, however, regardless of what I try. I uploaded a log with the ID: D523419666
  • Nevermind, I got iOS to connect by installing a non-self-signed certificate on the server. Don't know why the HTTPS worked for so long up until last week with a self-signed certificate.
Sign In or Register to comment.