Zotero 7 Beta: DOI URLs causing wrong parent information to be generated for imported PDF

After a few days of wrestling with a problem, I've narrowed down what's causing it. I kept trying to drag and drop a PDF into a Zotero collection from an external hard drive. It would work properly for a second. Then it would create a parent item with a totally wrong name, then change the PDF name to match the incorrect parent. I have my system set up to automatically create the parent item from the PDF and to rename the PDF using the parent's information. But why this seemingly random data?

I finally saw that a footnote in the PDF was the source of the metadata. I tried everything I could think of, but it never behaved correctly until I removed the URL on the footnote. But the URLs on other footnotes in the PDF were not causing similar problems. Here is the URL that caused the problem:


So I tried to create a different footnote in the document that also had a URL from the doi.org site. It did the same thing--renaming my PDF to match that particular footnote within it, rather than using the true metadata of the PDF.

I can only guess it has something to do with an attempt to extract metadata by looking for a DOI number within the document's text, but perhaps the code needs to ignore the number if it's in a footnote.
  • Yes, it looks for DOIs in the first few pages when trying to retrieve metadata.

    We'd want to see the actual PDF in question. Can you link to that, or send it to support@zotero.org with a link to this thread?
  • I sent it to the support email. The last footnote is the problem.
Sign In or Register to comment.