reporting a bug about the context menu location

I am reporting a bug about the context menu (the small page that opens up when you right click on one of the saved references).

So This is how I use zotero: when I want to save a reference, I find the bibtex of the reference, I copy it, and in the File menu, I select "Import from Clipboard".

I am used to storing copies of pdf files on my computer. So for the saved reference, I find its pdf on the web, I download it, and then, in zotero, I right click on the reference that I previously saved (this is where the bug occurs), and select "Add Attachment", and then, select "Attach Stored Copy of File..."

The problem is when I right click on the reference, the context menu opens up on random spots on screen, and when I move my mouse over it to open the sub-menu to select "Attach Stored Copy of File...", the sub-menu opens on another random spot on screen.

This does not happen when you initially open zotero, but happens when you add a few references, attach a few files, etc... not sure, perhaps, when you would use right-click (instead of left-click) to select items.

I use zotero on a daily basis. So it happens to me every day, every time I use zotero. It has been like this over the past few years, and each time that I was updating the app, I was expecting it to disappear. But it has not happen

I don't usually post on forums... That is why I did not report it earlier.

I have two screenshots to show the bug graphically, but it looks that users cannot post images on this forum.

My operating system is ubuntu 22.04
But it does not matter what ubuntu version you would use, as I said, I have been seeing this at least over the past three years

The zotero version is 6.0.30
Again, the zotero version does not matter either, as long as I remember it was like this

I tried to report this bug using the in-app window, but after clicking on "Report Errors", the software uploaded some statistics and gave me this code: 367-343-839, and asked me to come to this forum and report the bug manually!
  • To begin with you should know that the standard way to add items to Zotero is via the Zotero Connector browser extension. See Adding Items to Zotero.

    As for your issue, unless you can find a sequence steps after restarting Zotero that consistently reproduce this issue, it's unlikely we're going to be able to fix it.
  • edited November 28, 2023
    Yes, I know that there are other ways of doing it, I would prefer this way.

    I tried to reproduce it right now. Adding temporary references, switching between windows, minimizing the window, attaching files, etc. It happened three times. But still could not find the pattern

    What I could say for sure is that, the context menu opens up at a spot that previously was open, instead of opining at the spot that is currently right-clicked. so the location is not totally random
Sign In or Register to comment.