Problem with superscript and Word plugin

I've upgraded to zotero 2.0rc2 (directly from zotero 1.0.10) yesterday and installed the compatible word plugin (3.0a3).
I've a problem with a personal style which uses superscript vertical-align: whereas it should only put in superscript the"e" (see below), it does not stop "superscripting" and all the subsequent references are superscript. Here is the code:

<macro name="edition">
<if is-numeric="edition">
<group delimiter=" ">
<number variable="edition" form="ordinal"/>
<text value="e" vertical-align="sup"/>
<text term="edition" form="short" suffix="."/>
<text variable="edition"/>

[MS Word 2002, winXP SP3, FF 3.5.7]
  • as a workaround, what happens if you put
    in the next line?
  • edited February 3, 2010
    No change with that:
    <text term="edition" form="short" suffix="." vertical-align="baseline"/>

    But, surprisingly, if I add "sub" instead of "baseline", the subsequent references are subscripted:
    <text term="edition" form="short" suffix="." vertical-align="sub"/>

    Csl syntax summary indicates "baseline" but is it right?
  • baseline is right in csl, but I fear Zotero's csl implementation
    doesn't implement it. I got nothing then.
  • Indeed.... But I thought it was a problem with the word plugin since it was working with my zotero 1.0.10 and the compatible word plugin.
  • edited February 3, 2010
    fair enough - I believe someone else mentioned a similar problem recently, maybe Simon can have a look?

    ah, here it is - slightly different, but potentially related:
  • edited February 3, 2010
    I had not found the topic you were talking about, thanks. It's the same problem actually (on Mac)...
    If developers can have a look, that would be great!
  • (No surprise: no change with 2.0rc4...)
    Would it be possible to add "baseline" support in zotero implementation of csl? Or is it a mere plugin bug?
  • Alright, just bumped into this problem.

    Apparently the bug is not fixed it. (v. 2.0.3).

    Can anybody suggest a work-around? This looks like a pain to fix (I have _many_ references already entered in the document).

  • delenca - which problem specifically?
    Gracile was working on a custom style that's not in the repository.
    How are you seeing this problem? Using which style?
  • Oops, I meant the superscript citation not getting reset when we switch to a style that doesn't use superscripting. I.e.
    Perhaps I should post this comment there?

    Oh, and I found a work-around using search-and-replace that I think works.
  • I've had a similar problem.
    With a given citation style (AIP), I insert bibliography in MSword 2003 and should appear with number in superscript and the rest of the text (author, publication) in normal text.
    The original style has the following

    <layout suffix=".">
    <text variable="citation-number" vertical-align="sup"/>
    <text macro="author" prefix=" " suffix=", "/>

    I tried to create a new style where I made the following change

    <layout suffix=".">
    <text variable="citation-number" vertical-align="sup"/>
    <text macro="author" prefix=" " suffix=", " vertical-align="baseline"/>

    but it didn't work. I think this may be a problem with the word plugin
  • edited June 28, 2010
    Did you try this patch?. It works for me.
    Have a look on this thread.

    If you don't feel comfortable with that, just wait the next Zotero 2.0 release: the patch will be applied by default.

    EDIT: direct link to Frank's patch:
  • If you don't want to apply the patch on your own, it's also already applied in the 2.0 branch XPI, which you can install here. While the 2.0 branch XPI should be fairly stable, you should make sure to back up your library if you use it, and manually install Zotero 2.0.4 when it comes out.
  • When is 2.0.4 coming out?
  • I tried to apply the patch in the csl.js in the zotero.jar file (it took me a while to find it) using a combination of 7-zip to navigate within the file and rigt-click to edit with notepad++, added/removed the lines and it worked perfectly. Now in the bibliography in MsWord, only the number is superscripted, as I wanted for the style selected. I used this technique for patching because it ensures this patch is only temporary. Since I made no other change, when the new version 2.0.4 comes out it will still apply automatically, correct?
  • edited June 29, 2010
    Yep, the update should be offered in the usual way, and when it goes through it should scrub and replace the program code of your 2.0.3 installation. Glad to hear it worked for you.
  • edited June 29, 2010
    Since I made no other change, when the new version 2.0.4 comes out it will still apply automatically, correct?
    Yes, that's correct.
Sign In or Register to comment.