Cannot use LibreOffice plugin unter Kubuntu 22.10

Hi, I have downloaded the tar and unpacked it in ~/Documents/Zotero
I was not asked to install the plugin, probably bcs I tried installing the snap before(since removed) and I cannot get the plugin to work:

After manually installing, I receive the following error message:
( { { Message = "[JavaVirtualMachine]:An unexpected error occurred while searching for a Java, 11 at ./stoc/source/javavm/javavm.cxx:635", Context = ( @0 } }

any hints on what to do?
  • The LibreOffice Zotero plugin definitely works under Kubuntu. You should not be downloading anything separately, only installing Zotero, either via the archive download from, or from the deb repo. Then, install the plugin from Zotero Preferences -> Cite -> Word Processors, and if that does not work, see Manually Installing the Zotero Word Processor Plugins
  • edited 13 days ago
    I am really frustrated so maybe I am harsh ...
    After three hours of installing different JREs and uninstalling zotero countless times, I would really like to just get to my paper again ...
    I have used it on my machine at home, where I wilol not be before I have to present the paper ...

    I know that it technicially should work ootb, only it doesn't. the countless times I have now manually installed the processor plugin ...

    maybe get rid of everything and then start setting it up again ...
    Everytime I have to install zotero on tumbleweed or kubuntu, I already fear that I will not get anything done on that day. Something always goes wrong ...

    edit: and after manually installing the same: (unfortunately I can't attach images ...)
    ( { { Message = "[JavaVirtualMachine]:An unexpected error occurred while searching for a Java, 11 at ./stoc/source/javavm/javavm.cxx:635", Context = ( @0 } }
  • edited 13 days ago
    finally, I could install it - had to uninstall libre-office though and install 7.5 from their site.
    now, I don'T get an error message but no way of adding the zotero toolbar to libreoffice ui

    randomly re-enabling the processor several times worked ... now next issue:
    Zotero is not running says libreoffice, despite it being online and running ... might that be due to the synching in the background?
  • How did you install Zotero? Could you produce a startup Debug ID from Zotero?
  • this time, via tar. Before: snap, deb - got rid of everything.... (including {user}/.zotero this time) and it is finally up, at least the plugin and zotero itself ... now it seems to synch in the background. I can't enter zitations atm ...
    but that's probably bcs of the files not synched up ...
    I'll post later, whether everything is working ...
  • Synchronization is not related to the LibreOffice plugin. Does the Zotero LibreOffice Integration plugin appear in LibreOffice Tools -> Extensions dialog?
  • everything seems to work fine, now. thanks for your patience :-)

    1) LibreOffice version didn't work with the downloaded zotero (6.3) so I uninstalled what kubuntu came with and that fixed it (only now both my java installations are shown)
    2) always delete .zotero folder if you have problems :-D
Sign In or Register to comment.