Problems Zotero Connector


I have installed Zotero 6 on a new Windows 11 computer. I have also installed the Zotero connector for Firefox and for Edge. My primary browser is Firefox. When I rightclick the Zotero button in both Firefox and Edge while Zotero is running, I don't see any option to save anything to Zotero, not even the webpage or the webpage and metadata. I only see options to remove or manage the extension.
I have removed and reinstalled the connector, tried it on both Edge and Firefox.
What could I try to solve this?

Thank you.
  • edited November 12, 2023
    Make sure you're on a regular web URL — beginning with http:// or https:// — and not a local file or extension URL. Your browser should be set to preview PDFs, not download them first.

    Also note that you normally can just click the button to save to Zotero. You don't need to right-click unless you want to use secondary options.
  • Thank you, the behaviour I just described happens on any page, for example a book on Amazon. I know I can click on the Zotero button, however, I do like to right-click to see which translator Zotero uses and to try another one if it's available when I don't like the results I get from the default one.
    When I click Zotero connector in Firefox, nothing happens. When I click it in Edge, the Zotero webpage opens.
  • The Zotero webpage opens? What webpage?

    Does this happen with all other browser extensions disabled? Something very strange is going on on your computer if it's not working on any webpage in Firefox or Edge.

    Can you provide a Debug ID from the Zotero Connector for reloading an Amazon page and trying to save?
  • Thank you for your suggestions.

    The only addons I use on Firefox are Ublock and Zotero. Deactivating Ublock didn't help.

    I wanted to create the log in Firefox, since this is my preferred browser. However, after I had enabled logging, the usual Zotero options were available.
    I tried on Edge and the problem persisted, so I was able to create a log. The Debug ID is D1781204595.

    After creating the log, I closed Edge, reopened it and tried again. I was now able to add an item through Zotero connector. Could enabling and disabling logging have made any difference? Anyway, it seems to work for me now and I hope it will continue to do so.

    Thank you for your help.
  • No, enabling logging wouldn’t have mattered. But you should certainly always try restarting your browser if a browser extension isn’t working.
  • I did restart my browsers several times, since the problem persisted for several days before I wrote to the forum. I also restarted after reinstalling the addons.

    The problem is solved and it's okay, just writing this to say that something was very odd, just in case someone is experiencing something similar.
Sign In or Register to comment.