Zotero 7: Unique constraint failed

I was creating an area annotation that completely surrounded another area annotation (not sure if this matters). I then tried to change the color of the outer one, and saw that the annotation was "read-only". An error appeared at the bottom of the Zotero window:

Error: 'Error(s) encountered during statement execution: UNIQUE constraint failed: items.libraryID, items.key [QUERY: INSERT INTO items (itemID, libraryID, key, clientDateModified, itemTypeID, dateAdded, dateModified) VALUES (?,?,?,?,?,?,?)] [PARAMS: 6304, 1, "WX2E5E9N", "2023-11-12 01:38:38", 37, "2023-11-12 01:38:38", "2023-11-12 01:38:38"] [ERROR: UNIQUE constraint failed: items.libraryID, items.key]'

I tried to enable debugging, but nothing appeared to be logged and "submit output" was grayed out. Closing the tab and reopening seemed to fix the problem, albeit with the outer area annotation missing.

This is with version 7.0.0-beta.51+7c5600913 (64-bit) on Linux.
Sign In or Register to comment.