Server sync error

File sync stopped working, it throws an "invalid mod date" error on every sync. I checked the webdav server and it's working fine (I can login through other means and access the files). Here's the whole error message, it seems that one of the files has a modification date that Zotero doesn't like:

[JavaScript Error: "[Exception... "'Invalid mod date '910822784' for item 0_2NSNN5CF in Zotero.Sync.Storage.WebDAV_getStorageModificationTime()' when calling method: [nsIDOMEventListener::handleEvent]" nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)" location: "<unknown>" data: no]"]
  • That error should auto-correct. Are you getting the exact same error (with the same error) each time?

    If so, provide a Debug ID for the sync attempt.
  • Oh, actually, that's probably a bug. We'll fix this, but, out of curiosity, is the file in that directory (2NSNN5CF) legitimately from 1998?
  • Thank you, it did auto-correct after a while!

    The file is certainly not from 1998, but some of my files, for some reason (corruption when downloading? after downloading?), have extremely weird dates. Some of them are from the future! Yes I'm not kidding; dates like 2024 and all. Also, I have one file from 1956; even files last modified before they were created. Anyway, it's an extreme situation, but I simply cannot guarantee that a rogue program goes and changes the dates somehow... It's nice that it auto-corrects though, just be on the lookout for this in the future =|
  • BTW it only happened to a handful of files, so I can't rule out a virus or a glitch in the filesystem; it's not happening to tons of files anyway. Unfortunately, one of them was a PDF that I added to Zotero.
Sign In or Register to comment.