Word plugin error: "this._session.style is undefined"

Hi folks. I got this error message when trying to use Zotero citations in an existing Word document today. I've been using Zotero for my citations in it for about a year now, and all the upgrades have been fine, seemingly until now. Here's the message:

"this._session.style is undefined"

The error message appears when I try to do pretty much anything with Zotero, such as editing a citation, clicking the Zotero Refresh button, or clicking OK on the Zotero Doc Prefs dialog. The prefs dialog also shows up if I try to insert a new citation (just as if it was a brand new document).

I appreciate that I'm using a beta version of Zotero so problems happen, but obviously it'd be quite a hassle if I have to re-do all my citations from scratch. Is there any way to salvage it?


Zotero: 2.0rc2
Zotero WinWord Integration: 3.0a3
Firefox: 3.6
MS Word: 2003 SP3
OS: Vista Home Premium
  • first thing make an extra back up of the document.
    Have you tried changing the citation style?
  • Yes, I've tried switching styles. As soon as I click OK to the doc prefs dialog it displays the error message.
  • try if Zotero still works in a fresh document. If yes, try out the possibilities listed here:
  • Excellent. Copy + pasting the contents into a new document seems to have done the trick.

    Thanks very much!
  • My error reporting ID number is: 619606172
    I have a similar problem as the original poster. I had been using Zotero/Word with no issues, and then all of the sudden when I tried to insert a new citation, it gave me the "this._session.style is undefined" error message. Copy & pasting the document into a new document did NOT fix it, nor did performing the methods described in "Debugging Your Document" like changing the style in a new document, deleting part of the document to find the bad citation(s), etc. FYI, Zotero continues to create error messages when I attempt to add a new citations, so that's why I sent the error report. What can I do? Thank you so much to anyone who can help!
    Zotero 2.0.3; Word 2003; Zotero Winword Integration 3.0a4; OS Windows XP Professional
  • HI again. I decided to try uninstalling and reinstalling the Winword Integration Add-In and that seemed to fix my problem.
  • This keeps happening to me. One day a document is fine and then the next is produces this error message. Can someone tell me why this keeps happening and if there is something i should be doing to avoid this problem? it is frustrating to have to stop working to uninstall and then reinstall the Winword add-in each time.
  • ave8th:

    1) You're using an outdated version of Zotero. Upgrade to 2.0.8.

    2) Are you sure a Firefox and/or Word restart isn't what's fixing this? It's pretty unlikely that reinstalling the Word plugin would actually accomplish anything.

    3) What style are you using, have you tried with other styles, and does this happen in new documents?
  • Hello,

    Error report ID 1719848977

    I am running Zotero 2.0.9, plugin 3.0b5, and Word 2011. I just started having this problem. Neither changing styles nor cutting and pasting into a new document changes anything, and I can't insert citations in an empty new document, either. I first noticed in an autosaved recovery document after an OS X crash, but I can't be sure that's when it really started. It's not an emergency or anything for me; just trying to help sort it out.
    Thank you!
  • What style are you using? Does it work if you choose another style?
  • Changing styles does nothing. I normally use Chicago with bibliography.
  • Try resetting translators and styles in the advanced pane of the Zotero preferences.
  • Hi,

    I have been using zotero for more than one year and I have started to have problems from yesterday when I installed Windows 7, Word 2010 (in spanish) and the beta version of zotero. The style I'm using is American Soc. Asociation; I've tried to change style, but I couldn't. I have tried everything what is suggested above (even reseting translators and styles... and I have tried other ways too such as removing from the library and text which I thought was a conflicting item). I have received diverse error report with the same problem..

    This.registry.citationreg.citationById[c[0]] is undefined

    'Zotero is experiencing and error updating your document.
    Citation is undefined'

    'a field note is corrupted'...

    Also some references have changed (e.g. 'Bourdie 1991' which was bellow in the text appear when should be 'Pink 2006' for example... That's scaring!).

    What should I do. Help!
  • I made a new documented before and it worked well for a while, but then I had problems again. Now I'm doing the same, but it is not working!
  • ceramire: You should probably start a new thread; this discussion started with a Zotero 2.0.x issue, but from the error messages you are receiving, it looks like you're running Zotero 2.1.x. The internal code that handles citations in the two versions is very different, and the discussions should be kept separate for clarity and to avoid confusing other users.
  • Hello,

    i had the same problem with an odt document. I copied an old document and made my new text there. Then i wanted to insert some citations, but the same error came. I clicked on unlink citations and now it works again.
    I hope that error won't occur again, because it wouldn't be so fun, if I must unlink my inserted citations.
  • Just wanted to give a +1 to Dan Stillman's suggestion to restart Firefox. That solved this problem for me and was a much easier fix than many of the other suggested troubleshooting steps. I would try that first before doing anything else.
Sign In or Register to comment.