Can't override lock in Google Docs

This discussion was created from comments split from: Google Docs issues.
  • I am having this issue. Zotero says multiple users are using zotero, even though all editors forced quit Zotero. We also cannot override the lock. I tried making a copy but the problems were not solved.
  • @elfst022: What do you mean when you say you cannot override the lock?
  • All users have exited zotero, however I get this notification:
    "The document citations are being edited by another Zotero user. Please try again later."
    I click "need help"
    This message shows up: "Would you like to override the document lock?"
    I click "yes" and then nothing happens. I am unable to refresh the document or add any additional citations.

  • Can you provide Debug IDs from Zotero and the Zotero Connector for reloading Google Docs and trying to override the lock?
  • I have a Debug ID, can you provide more information of how to proceed?
  • You need to tell us the two Debug IDs.
  • I have one? The Debug ID is D1470113407
  • I asked for Debug IDs from both Zotero and the Zotero Connector and linked to instructions for both. You provided only one, from the Zotero Connector.

    But we can start with this.
    [JavaScript Error: "Error: Too many changes applied before saving document. Please save changes in smaller batches using Document.saveAndClose(), then reopen the document with Document.openById().
    at chrome-extension://ekhagklcjbdpajgpjgmbionohlpdbjgc/messaging_inject.js:79:17
    at async Zotero.GoogleDocs.ClientAppsScript.setDocumentData (chrome-extension://ekhagklcjbdpajgpjgmbionohlpdbjgc/zotero-google-docs-integration/clientAppsScript.js:128:5)
    at async (chrome-extension://ekhagklcjbdpajgpjgmbionohlpdbjgc/zotero-google-docs-integration/clientAppsScript.js:59:13)" {file: "[object Object]"}]
    How large is the document?

    You should disable all other browser extensions, restart your browser and Zotero, and try again. If you're still having trouble, restart your browser again and provide Debug IDs from both Zotero and the Zotero Connector for reproducing this.
Sign In or Register to comment.