references becomes mixed up in the bibliography and the text

This discussion was created from comments split from: Second reference appears as 1 again.
  • I discovered the same problem - the numbering of the references becomes mixed up in the bibliography and the text.

    E.g. I write add references to Adams, Brown and Cherry in that order. Superscripts 1, 2, and 3 appear in the text, but then the reference list is:

    1 Brown reference
    2 Adams reference
    3 Cherry reference

    In a seemingly random order. I had a look at the CSL code but couldn't see where the problem has arisen.
  • Which style are you using?
  • (@KSteiner1: Please start new threads for new issues. You misunderstood the other thread, which is about a totally different issue. I've moved this to a new thread.)
  • Sorry, and thank you. The style is Vancouver (superscript).
  • Does this happen in a new document or just in the specific one you're citing?
    What happens when you switch to an author date style: do you see the parenthetical citations in the order you expected them (i.e. Adams, Brown, Cherry)? If so, does switching back to Vancouver then look correct?
  • edited October 13, 2023
    It happens in any new document.

    If I switch to an author date style (Harvard) the parenthetical citations are in the correct order.

    Switching back to Vancouver (superscript) changes the order of the reference list back to the wrong order again.
  • I don't think we've seen this before. Any of them in figure captions or tables?
    Does this happen with other numeric styles (try Nature or IEEE, e.g.) too?
  • I've realised I'm probably actually wasting your time (apologies).

    I'm actually a RefWorks user. I made my way here because I was having this issue in RefWorks, and assumed it was a general problem with the style. When I tried to look up how to suggest a correction, I was sent here from

    However, I have just tried the style in Zotero (I'm a librarian so I use/teach both), the ordering works fine. It is just a problem with the style in RefWorks, which to me implies there is something going wrong with how it works there, but not an issue with the style itself necessarily. Not sure that's going to be fixable as I have no idea how RefWorks uses the CSL styles! But at least it works fine in Zotero.
  • Yeah, unfortunately RefWorks' CSL implementation appears pretty buggy and it's closed source so we are completely unable to help with it.
  • Apology accepted. I'll just note that you ended up here because a corporation with $1.2 billion in annual revenue can't be bothered to produce software that actually works even when offered all the free code to do it nor provide its own technical support. I hope as a librarian you'll take that into account when recommending good solutions to your users.
  • $2.6 Billion, but who is counting :P
Sign In or Register to comment.