New computer and Zotero library is empty

I just got a new laptop and downloaded Zotero onto it. I logged in and had sync on. My (very large and organised) library I was using on my previous laptop popped up in terms of all the folders and subfolders but they are all empty - 'no items in this view' with the exception of 'duplicate items' and 'unfiled items'. I have tried the troubleshooting tips others have posted but nothing seems to work. Can you help?
  • What do you see under "My Library" on this website?
  • Do you mean storage on this website? It says 0 mb.

  • No, I'm asking you how your library looks when you look at it on the website (sorry "Web Library" not "My Library", that changed a while ago)
  • It looks the same as in the software - I have all of my folders but when I click on any one of them - 'no items in this view'
  • It's odd because the library looks the same on both computers but I have all of my references in the folders on the old computer and none of them on the new computer
  • edited September 24, 2023
    I'm guessing this is a misunderstanding and you just had View → Show Items from Subcollections enabled on your other computer and haven't enabled it on this computer, and you're only looking at top-level collections on this computer. You have thousands of items in collections.

    (You also have 21,000 top-level items, which you can see in the library root, so your library certainly isn't empty.)
  • Thank you, I've tried that in view but with it ticked still not seeing the items. Is there another way of enabling it?
  • Can you give an example of a collection that you’re not seeing items in in the web library?

    And can you can acknowledge what I said about the library root? You see all your items there, yes?
  • I can see many items in the library root but there are also lots of blank spaces and it doesn't look the same as on my old computer. All of the subcollections are empty. One example is the one called 'Centenarians' and all of its subfolders
  • Oddly, I can now see the appropriate references in the 'Centenarians' subfolder but none of the other multiple subfolders. Any ideas? The show items from subcollections selection remains ticked.
  • Oh, there's no mystery here: the reason you're not seeing the same library is that you haven't uploaded any items since 2021. You would've been getting a sync error on your other computer that you haven't resolved, indicated by an error icon to the left of the sync button that you can click on for more details. You'll need to go to that computer and resolve whatever problem it is so that the rest of your items can be uploaded.

    (In an upcoming version, we'll be showing a more prominent banner across the top if a sync error isn't dealt with for a while.)
  • Thank you. The error I'm getting though is 'The creator name 'Smith...' in one of your items is too long to sync. Shorten the field and sync again'. This seems to be for a very large number of items. Is there any quicker way to resolve this?
  • Why do you think it's for a very large number of items? It might be — this is usually caused by a malformed import (e.g., a RIS file from some program that included author names incorrectly) — but you wouldn't necessarily know that from the error message. There could just be a handful, and fixing those would allow the rest of the library to sync.

    But no, you'll need to fix these to allow it to sync. (It's best to address these right away, when the sync error message first appears, so you can delete and correct the entire import or identify a specific site that's exporting these incorrectly so we can adjust our import code.)
Sign In or Register to comment.