Run-time error '5' with Word for Mac in Zotero 6.0.27

  • just reporting to the community. I have the same error 5 issues every time I try to cite references from Word for Mac since updating to 6.0.27. Reinstalling 6.0.27 does not solve the problem. Downgrading to 6.0.26 solves the problem.

    Note: Before downgrading, I tried deleting Zotero.dotm reenable/reinstall Zotero plugin etc etc etc. When reinstalling 6.0.27, I have also done the above items.
  • (The thread you posted to was about a similar problem caused by CrowdStrike security software. This is different, so I've moved this to a new thread.)

    Is this an institutional computer? Is there any non-standard security software on the system or policy restrictions on the Word installation?

    Zotero 6.0.27 changes the mechanism the Word plugin uses to communicate with Zotero for macOS Sonoma compatibility, so some security software or settings might need to be adjusted to allow the new communication method, and we're trying to figure out what that might be for the people experiencing this.

    You can tell your IT department that Zotero 6.0.27 uses curl from VBA to make an HTTP request to the Zotero app at, since Sonoma blocks the previous communication method, and ask them whether there’s any security software or policy restrictions that would be blocking that.

    We're also testing a new version of the plugin that should restore the previous communication mechanism on non-Sonoma Macs. You can test that by downloading this version of Zotero.dotm, moving it into your Word Startup folder, and restarting Word. Please let us know if that fixes the problem for you. But be aware that this problem will reoccur once you're upgraded to macOS Sonoma, so you will need to work with your IT department to figure out what is breaking the plugin version in 6.0.27.
  • Same problem here - Run-time error '5'
    Reverted back to Zotero 6.0.26 - also same error in beta 7. version
    I deleted previous .dotm file in Word Startup and replaced it with the one recommended in an earlier post. Rebooted.
    Mac OS: 13.5.2
    Word: 16.77.1
    Any suggestions - apart from going back to Endnote which has my IT dept support...
  • edited September 24, 2023
    @SteveHaines: I'm not sure what you're saying here. If you revert to 6.0.26, reinstall the plugin from the Zotero settings, restart Word, and still get this error, it's not the same problem. As I explain above, this is specifically due to a change in the 6.0.27 plugin, which was just recently released. But the "Run-time error '5'" is a fairly generic error that has occurred for a small number of people over the years for various reasons, seemingly due to some sort of restriction or misconfiguration in their Word installation. If this didn't start with 6.0.27 for you and/or reinstalling the 6.0.26 plugin doesn't fix it, you should start a new thread.
  • edited September 25, 2023
    @dstillman My MacOS is Ventura 13.5.2, and my computer is a university-managed one but I have the admin privilege. I tested a few times and can reproduce the problem: Zotero 6.0.27 causes error 5 while Zotero 6.0.26 does not.

    What is currently working for me: running Zotero 6.0.26 with auto-update disabled. I feel extremely hesitant to reach out to our university IT as it can be pretty hairy in the middle of a semester.
  • edited September 25, 2023
    @jaywen: Can you test the Zotero.dotm I link to above? That should fix this for pre-Sonoma systems, and if so we’ll make that available in 6.0.28 and Zotero 7. But if you’re affected by this, you’ll need to talk to your IT department before upgrading to Sonoma, since the old method won’t work on Sonoma.
  • @jaywen, @SteveHaines: If you're still getting "Run-time error '5'", please try updating to Zotero 6.0.28, which was just released, and let us know if that fixes it for you.
  • edited October 12, 2023
    All sorted! The sun is shining! Everything is coming up Millhouse :-). Many many thanks @dstillman
  • PS Since I posted this error my computer was updated to Sonoma...
Sign In or Register to comment.