Importing references using DOI failed

Debug ID:D527581981
DOI :10.1016/j.mayocp.2016.12.014
Starting this week, when I import a DOI to add a reference, the following appears:“Zotero could not find a record for the specified identifier. Please verify the identifier and try again.”
I disabled all third-party plugins and restarted, but it still doesn't work.
But it works when entering PMIDs.
  • We've had to block your IP address :-(
    You're being blocked by Crossref.

    Have you tried to import a large number of references by DOI?
  • Yes, I'm so sorry about that.I don't fully understand the usage rules of Zotero
    In the past few weeks, I have been sorting out previous references and importing them into Zotero for better management.
    Could you please remove me from the block list?
  • The block is from Crossref, not us.

    Approximately how many DOIs have you tried to import this way?
  • Thank you.
    About 20-30.
  • OK, we've made a change to how DOIs are looked up that will hopefully better avoid blocking like this when trying many DOIs at once.

    I'd wait a day and see if the block goes away automatically. If not, let us know.
Sign In or Register to comment.