Something curious that doesn't seem to be Zotero's fault. "Zotero is disabled" import error.

I was sent a link to a pdf file to a Wolters-Kluwer journal article. In place of the usual download icon there was a red Z and when I hovered over it I received the popup "Zotero is disabled".

I was able to find the article by Googling the article title plus an author. I downloaded the metadata to Zotero from there -- the html version instead of the pdf.

I accessed the article via Firefox 117.0.1 (64-bit) where the file is actually downloaded to my SSD and in the URL field is an address on my own machine.


Is there something I can do to avoid this seeming blocking of Zotero? This isn't the first time this has happened with Wolters-Kluwer pdf files.
  • Check the URL when looking at the PDF -- Is guess you are seeing a local (file:/) URL. Zotero can't work on local files
  • That's what I suspected. However, this is happening more and more since the most recent Firefox update. Is there a setting to have Firefox display PDF files from the publisher instead of downloading the file?
  • It's just a single setting. You have to set PDFs to "Open in Firefox" instead of "Save File" (which, confusingly, also opens in Firefox).
  • (though I am pretty sure sites can somehow ignore that setting,)
  • Oh, yeah, if a site returns Content-Disposition: attachment or uses the newer download attribute of <a>, that probably forces a download regardless of that setting, which might cause Firefox to display it with a file:// URL. Sites really shouldn't do that for PDFs, though!
Sign In or Register to comment.