Library not loading, unable to load translators and styles

Hi everyone,
I would appreciate your help with a problem I have experiencing with Zotero (report id: 519619406). I started getting the message that Zotero was unable to load translators and styles. Shortly after, my library disappeared. I have tried different things:

-resetting translators and styles,
-checking for database integrity (all fine)
-coping the "storage" folder to the default Zotero local directory, to see if the problem was related to the fact that I was using a Google Drive folder as a custom data directory location.
- I have tried to delete the .sqlite file plus some other sqlite files to check whether they were causing the problem (e.g., "zotero (francesco cabiddu's conflicted copy).sqlite")
- after noticing that nothing works, I have readded all the deleted .sqlite files into the Google Drive custom directory, and I am now unsure how to proceed.

I can see the storage folder with my pdfs and references present, so fortunately my literature is still there, but somehow is not picked up by Zotero anymore.

Don't know if it might help, recently I followed a guide to link Zotero notes and comments to Obsidian, and in order to do that I have installed Zotfile and Betterbibtex. I am also working on Windows 10.

Thanks very much in advance for your help,
  • You had your data directory in a cloud storage folder, despite warnings within Zotero itself and in our documentation not to do so, so I'm afraid you're totally on your own here.
  • Hi,
    I was not aware of this issue. Now that I've read a bit more about it, I understand why your response did not offer any solutions. You likely encounter this issue frequently from inexperienced users like me.

    However, it would have been helpful to receive more practical advice. For example, moving the Zotero directory out of Google Drive and then using an old sqLite file to recover the library solved the problem for me.
  • edited September 21, 2023
    The theory may be that because the option to change the Data Directory Location is relatively deep in the Preferences under Advanced\File and Folders that only advanced users will find it/use it. And will be able to extricate themselves via good backups if it goes pear-shaped. But the setting itself looks innocuous - it's there, why not use it ?

    It would perhaps be a good idea if there was a strong warning attached to that *particular* setting, and/or an explicit link to the above documentation warning. Having said that, if you click on Help it takes you here, where there is such a warning:
  • Zotero does warn you if you place your data directory into folders recognizable as Synced folders (e.g. Dropbox). IIRC, that's not necessarily the case for GDrive, though, since you can designate any folder on your computer as the GDrive sync folder (I think?)
Sign In or Register to comment.