Switching from Google Docs to Word document and vise versa

Whenever I try to switch between the word processers the references are unlinked automatically I believe. I followed all the instructions provided on the Zotero website to transfers the document from word to google and vise versa. It was unlinked every time. Is there any way to fix it?
  • Yes I did follow that the instructions provided on that link. Moving ahead with reporting
  • edited September 18, 2023
    Report ID: 132708353

    When I upload the document from local computer to google drive the citations are unlinked in the document. It's the same when I download the document from google drive to my local computer and then try editing with MS word.

    1. Uploaded the document to drive.
    2. Made a copy of it and saved it separately.
    3. Switched the word processor on the Zotero software (and tried through google docs too)
    4. try editing and adding a reference. the refences list starts from (1)

  • That doesn't sound like you're doing this right, though. The Transfer document wouldn't have typical citations in it, it'd have a bunch of Zotero codes and an all caps note at the top
  • edited September 21, 2023
    I have the same issue going from Microsoft Word to Google Doc. The document has a bunch of Zotero codes and the note at the top, but refreshing the document and all of the other suggestions in the troubleshooting instructions didn't work.

    I found the error message was due to Google Drive not actually opening the Word Doc as a Google Doc. Opening it as a Word Doc and then saving it as a Google Doc under the file tab did work and the error message no longer occurs. However, after clicking "Restore Citations" on the Transferred Document pop-up, the error message resurfaces.
  • Report ID: 891746297

    Zotero 6.0.27 and Google Docs on Chrome Version 117.0.5938.92 (Official Build) (arm64).

    1. In Microsoft Word, under Zotero tab, Document Preferences, Switch to a Different Word Processor.
    2. Upload document to Google Drive.
    3. Open document. Save as Google Doc.
    4. In Zotero tab, click Refresh, click Restore Citations.


    Updated Chrome and Zotero (not needed).
    Restarted Chrome.
    Restarted Zotero.
    Changed the Document Preferences on Zotero tab in Chrome.
    Turned off all extensions.

    Other Google Documents work fine with Zotero. Problem stems from switching from Microsoft Word to Google Doc.
  • Does this happen with a new sample document you create in word and attempt to move to Google Docs? If not, you will have to follow the Troubleshooting Errors in Word Processor Documents instructions, specifically the last step, but you will have to cut the document down before attempting to transfer. Do not get discouraged, this may seem that it would take a while, but even for a very large document it should not take more than 10 steps to cut it down to a single page.
  • edited September 22, 2023
    "Other Google Documents work fine with Zotero. Problem stems from switching from Microsoft Word to Google Doc."

    I don't have any problems using the Zotero plugin in Word.

    It's a 41 page document that is over 150 pages when Zotero reformats it for export to another format. It gives the error even when divided. As for the last step in the Troubleshooting Errors in Word Processor Documents instructions, that's laughable for large documents. It would be faster for me to redo each citation in Google Docs.
  • "Other Google Documents work fine with Zotero. Problem stems from switching from Microsoft Word to Google Doc."
    That wasn't the question, though. The question is if the process of *switching* works with other (test) documents.

    For the last step in the troubleshooting, again, binary splits work exponentially. Getting even a 1000 page document down to 1 page by splitting it in half takes 10 splits.

  • No, it did not work with the test documents I created. The same error occurs in the process of refreshing the Google Doc to update the citations.
  • Are you able share the test doc (obviously not the actual one) here (i.e. set to to everyone can edit and post the link here)
  • Share the Word Document or the Google Doc link? Or both?
  • Both the Word document uploaded to GDrive and the Google doc might be most helpful -- unclear what's going on, so the more possible variables we can look at the better.
  • edited September 22, 2023
    I'm not really comfortable sharing my personal Google account with the general public on a forum like this, and it looks like I'm not able to create a second Zotero account to act as a dummy account for the purpose of sharing.

    Edit: I'm not sure if this will work, but I created a dummy Gmail account for this purpose and attempted here. Same errors.


  • Thanks -- I can replicate this. @adomasven I can replicate in Firefox with Z7 both with the linked doc and with a new doc I create (also happens with transfter from ODT, btw.).
    Debug from the FF connector: D1186650412
  • Any suggestions?
  • edited September 27, 2023
    Sorry about this — we fixed this a couple months ago, but the fix didn't roll out properly.

    This should be fixed now in the latest Zotero Connector for Firefox (5.0.113), and we've submitted new versions of the Zotero Connectors for Chrome and Edge that should be out in the next day. The fix for Safari will be included in the next Zotero update (6.0.28 and the next Z7 beta).
  • Great, thank you!
  • Just successfully transferred it in Google Chrome. Thank you both so much for the help!
Sign In or Register to comment.