My Entire Library Just Deleted — Please Help

A few days ago I logged into Zotero Web browser on a loaner laptop in our research lab — I wanted to sync my library. Admittedly, I was distracted and helping people as needed with other tasks, and started this task and couldn’t return.

When I just opened Zotero on my personal iPad, my entire library appears to be gone. It tells me there are 4 sync errors but not much more. I have tried to follow steps to correct this but the iPad interface is quite different. It contains so much of my PhD work. Please help!
  • You (or perhaps someone on a computer where you left yourself logged in) deleted all the data in your library and emptied the trash.

    Assuming you've been using Zotero on a desktop computer as well, which it looks like you have, you can likely restore at least your data — if not files — from one of the automatic backups Zotero makes and use Replace Online Library as described there.

    (That's assuming you've synced the desktop computer already. If you haven't, your data would still be there, so you can just disable your computer's network connection before starting Zotero, temporarily disable auto-sync, and then use Replace Online Library after re-enabling your network connection.)

    In either case, you should make a copy of all zotero.sqlite files in your Zotero data directory before starting Zotero.
  • Thank you. This is very helpful.

    The challenge is that I am “between” desktops. I was trying to sync my library onto a new laptop, but I have for the last two months primarily been working from my iPad. I was able to retrieve a backup from my previous desktop last night by disconnecting from wifi to prevent updates. While this is better than nothing, it is a back up that is a couple months old and I have lost significant work.

    Is there a way to retrieve a back up from my iPad itself? If i restore my entire iCloud backup from a week ago, can I still recover the app data? Or will it connect to the current state of the Zotero app. I tried logging in to the web version but again I could not see my library.

    I also made copies of all Zotero.SQLite files as soon as I realized I was experiencing an issue. Thought these too appear to contain only shared library data and not my personal library.

    Additionally, when I open Zotero on my iPad, it does notify me there are 4 sync issues. Is it possible something else is going on?
  • edited 14 days ago
    No, it's not possible to restore from a backup of an iPad, sorry. And no, any sync errors on the iPad aren't relevant. Someone deleted your library data and emptied the trash.
  • Thank you so much. Last thing - I am sure Zotero will have my backup in their cloud at specific restore points or snapshots from their servers. Is it possible for me to get my library/backup from Zotero Support as I have lost months of my research and it would save me at least six months of rework?
  • No, we don't offer any sort of version history at this time, sorry.

    Again, any Zotero desktop app that had been actively syncing would've been able to restore to data no older than a day or two using the automatic backups. But if you've only been using the iPad app, I'm afraid whatever older desktop backup you find is the best you can do.
  • Well, that clarifies everything. Thank you, your help has been amazing.
Sign In or Register to comment.