pdf attachments not syncing - perhaps?

Report ID: 645320976

After adding an attachment to an item in my library I tried to get it renamed according to the parent item, but that did not work. I then renamed the attached pdf manually. However, when I double clicked the parent item I got the message that the attachment could not be found (the original name was referred to).
On opening the storage folder on my device I found the pdf with the name I had manually given it. But in my web library no symbol for a pdf is associated with that item.
  • [JavaScript Error: "Unix error 21 during operation read on file /media/[…]/Zotero/storage/TJUPU3VK/[…].pdfd (Is a directory)" {file: "(unknown module)" line: 0}]
    Because it's not a PDF — it's a folder (maybe a "PDF bundle" from Skim?). This isn't something supported by Zotero. I'm not even sure how you added that to Zotero, but whatever behavior you saw is undefined.
  • Hi Dan. Thanks for your very quick reply.
    Yes, I should have read the error report. Those bundles are from my Mac days using Skim. Removing the bundle stops the sync error.
    The problem I described was actually something different which I solved by trashing the attachment and then reattaching it.
    Thank you for all your great work.
Sign In or Register to comment.