Better-Bibtex restores the deleted .bib collection

I have had a collection of .bib files and started to learn Zotero. I imported the collection to Zotero and made "keep updated" with this collection. Then I imported more .bib collections and made "keep updated" for all collections. Then I deleted the first collection in Zotero and in the disk too, and cleaned all additional folders in Zotero such as "Deleted" and "Duplicates". But I was very surprised that the deleted collection has been restored in the disk (not in the Zotero). I supposed that it was connected with the synchronization library with Zotero and I broke off the sync. But the collection is still restored nevertheless. I inspected the Better Bibtex preferences and found that the deleted collection is still in the "Automatic export" list, and there is no option to correct this list. To solve this problem I deleted the folder "better bibtex" and files better-bibtex.sqlite and better-bibtex-search.sqlite and restarted Zotero. The list of synchronized collections becomes empty now. I made once more "keep updated" to the rest collection. The deleted collections are now not restored. I think it must be possible to correct the list of synchronized collections. But maybe I missed something in preferences?
  • You should be able to disable auto export in that part of the BBT preferences
  • This is the problem. I did not disable auto export for this collection before deleting the collection. After deleting there is no possibility to disable. There is no option to "disable auto export" in BBT preferences.
  • Hi If you look further you could see a tab with collections that are active in BetterBibtex, you could just delete those you don’t want experted in BetterBibtex settings, it’s disable autoupdating but don’t delete files on disc
  • After deleting there is no possibility to disable.
    This is false. You will find your auto-exports in the BBT preferences, and you can always remove them there.
Sign In or Register to comment.