Not downloading files from WebDAV server in Win10 & MacOS

I am using a WebDAV server to sync files across multiple devices. It works fine for an iPhone and an iPad under the same network environment, downloading attachments and syncing notes in pdf correctly. However, I cannot get the Zotero in a Win10 and a Mac to download files from the WebDAV server. The .prop and .zip files stored in the WebDAV server can be accessed correctly via file explorer/finder in the same device, but Zotero won't download them in syncing.

Debug ID: D610033650 (sync success but not file was downloaded)
Debug ID after sync history reset: D721827011

Thanks in advance for any help.
  • What's the 8-character key of the file you're trying to download?

    Did you move files from another WebDAV server?

    If you're sure the .prop and .zip files for the file you're trying to open exist on the server, you may need to upload another file — either on this computer or another computer — to trigger new downloads. There's currently a bug where a reset doesn't fully force downloads if no changes have been made elsewhere.
  • There are a bunch of papers in the library I tried to sync, but I've checked that the keys in the local Zotero/storage files do have their matching counterparts .prop and .zip in the WebDAV directory. (For example, like 6N79LCTH, it is accessible from directly opening the .zip file in the server, or accessing from the Zotero app newly installed on an iPhone).

    There had been no change ever since the setup of the WebDAV server. I encounter the downloading issue when I tried to set up the syncing on a new Win10 machine and a Macbook. Then I also tried to set up on a new iPhone using the same setting for WebDAV server and under the same network environment, which worked without issue.

    I also tried to upload files from Zotero on the Macbook/Win10/iPhone, and the uploading all succeeded, but they could only be downloaded on the iPhone but not on the Macbook or Win10.

    I am not sure if this satisfy your suggestion for uploading file to trigger downloads. It seems that the uploading could be done on all devices but the downloading could only be done on the iOS ones.
  • For example, like 6N79LCTH, it is accessible from directly opening the .zip file in the server, or accessing from the Zotero app newly installed on an iPhone
    OK, and can you provide a Debug ID for trying to open that file and having it not be found?
  • Submitted. ID is: D1038451105
  • File syncing is not active for item's library -- skipping download
  • Sorry for the late reply. Missed the notification email for your response.

    I am not sure I have correctly enabled the syncing for the library. I’ve ticked the “Sync attachment files in My Library using WebDAV”, tried both the “Download files at sync time/as needed” settings, and passed the Verify Server, though getting the “uploaded file was not immediately available” warning.

    With the same settings in the same network environment, my iPhone and iPad could download the attachments properly, but Mac and Win10 are still not syncing. Is there any other additional setting I need to do to enable the syncing?
Sign In or Register to comment.