Zotero 7 beta - inking problems

Very happy to see ink annotations added to Z7b.

I noticed two problems:

1. Curved pen strokes are approximated by very noticeable straight lines.

2. The pen tool doesn't disengage after starting a stroke. This occurs both with my graphics pad and with the mouse.

System info
OS: Ubuntu 20.04
Zotero: 7.0.0-beta.29+f0e1da23b (64-bit)
Graphics pad: Gaomon S620

Let me know if there are any other details which would help (also please respond if you can replicate).
Thanks to the Zotero team for their ongoing effort!
  • 1. We'll fix that.
    2. Does it happen all the time or only in specific circumstances?
  • Thought it was all the time but further testing shows it's specific

    Steps to reproduce:
    1. Open a PDF in the Zotero reader
    2. Select the pen
    3. Draw a stroke
    4. Select the eraser
    5. Erase the *entire* stroke
    6. Select the pen
    7. Draw another stroke

    The pen tool should stay engaged after releasing the mouse or pen contact.
    Step 5 is quite specific, if you erase part of the stroke the problem doesn't occur. If you draw multiple strokes, the problem only emerges when you erase all of them completely.
    (As a completely unrelated piece of feedback, I'd also vote for a separate selection tool. Integrating ink selection into the pen makes it impossible to write without selecting the last letter I wrote.)
  • I can reproduce it now. Thanks.

    Yes, we may make changes regarding the selection.
  • I found myself running into the second problem noted by refmitchell today and found this post. I am wondering if there is a temporary fix for now?

    Thank you for your consistent effort in developing Zotero!
  • @DianaS1108 The previously mentioned issue should already be fixed. Are you using the latest beta? If so, try to describe the exact steps how to reproduce the issue.
  • I just want to add that Im using the latest Zotero beta and when im trying to draw with my pen, when I lift my pen, the stroking doesnt stop and its just acting weird.
    Also the entire pdf/page moves when I try to draw.
  • @Eneswar Could you make a video demonstrating the issue?
  • https://imgur.com/a/exs1vZs

    First of all this is a xp-pen stylus, and what you see in the video is.

    1: When I have the pen on the drawing board and im drawing, instead of drawing its moving the page up and down.

    2: When its actually drawing on the video, I dont actually have the pen on the board at all, its slightly hovering over the drawing board. This means lifting the pen away from the board doesnt start over the strokes, its stuck with the initial drawing.

  • @Eneswar Interesting. The pen is doing something untypical. But I'm not sure yet how to reproduce this to fix the issue.

    Does the pen draw ink annotations in other PDF viewers correctly?
  • I have tried it on Adobe Acrobat and I didnt have the same issue. If there is a specific app you want me to try Ill gladly do so.
  • @Eneswar Let's try drawing with the original PDF.js version. Select the pen in the toolbar and start drawing. Does it work well?
  • edited January 19, 2024
    I assume you want me to try this directly via the browser, and I did, both on Edge and Firefox, and both times it worked perfectly fine just the way I would expect it to work.
  • Just wanted to add that the issue still persist with the new update.
  • Pen was working for a while for me, but just started having this issue. Interestingly, the issue goes away when I turn off windows ink (but then the inking quality is awful).

    Using a wacom intuos tablet on windows 11 right now. Fiddled around both with pen/tablet settings and with windows ink settings, but issue persists. Issue also only happens in the zotero app (inking works fine with windows ink enabled in the edge browser when inking a pdf).

    Curious if anyone has figured out a solution as it seems to be some sort of input miscommunication between windows ink and zotero.
Sign In or Register to comment.