PDF not synchronizing after adding it in iOS Zotero app

Debug-ID: D1584646389

Hi everyone! I have a problem with sync from iOS after adding an attachment on iOS to Zotero (via "add attachment" button in the file record). It only synchronizes the name but not the file. I am using Zotero storage for sync (unlimited plan). In my online library the file shows up as greyed out and I cannot open it. On my laptop the file shows up but gives me an error message when trying to open it:

"The attached file could not be found at the following path:

I tried finding the solutions here (https://www.zotero.org/support/kb/files_not_syncing). I did not find a sync error on my iPad, yet after checking the online file library, step 5 only addresses computers, not iPads. So I do not know how to continue now.

To re-create the problem, I have run debug output logging to add a file the same way and then sync. After checking that the same error appeared again, I stopped the log (see debug-ID above).

(The actual file that I would like to synchronize has annotations in it. If, for some reason, sync won't work directly, is there a way to export the file with annotations from within iOS?)

Any and all help would be greatly appreciated!
  • edited July 12, 2023
    You seem to have a large ongoing sync in that Debug ID. We'll need to see a Debug ID for adding a file once your library has fully synced, if the problem is still occurring.
  • edited July 12, 2023
    Interesting, thank you. How do I know when the ongoing sync is done to retry? (The green sync arrow on my laptop Zotero app is not swirling currently.)

    I just logged the same again, in case it's already better: D1835329110 (The issue still persists.)
  • edited July 13, 2023
    The sync was still going for that Debug ID as well. You have a large number of annotations in your library, so it can take some time for those to sync the first time.
  • @ojobr: Oh, wait, it's not an initial sync — it seems to be performing a full sync after encountering an error.

    We'll investigate, but you can try searching for "TFDGD5LG" in the search bar. With any luck, that will bring up a note (or a parent item of a note). If you copy the note content into a new note, delete the old note, and empty the trash, that might fix this.
  • Thank you! I did find a note with that search term. I copied the attached note's content into a new note and deleted the original note, and emptied the trash. My iPad is not on me currently, so I will check when I get home whether it solved the problem and will let you know. I appreciate the help!
  • Thank you for your help, it worked! Problem solved. :-)
Sign In or Register to comment.