Zotero 7: Add Notes from Annotations not working

On Zotero 7 beta the "Add Notes from Annotations" feature does not work. Maybe this is already known.

The feature works just fine for me on Zotero 6.
  • So nothing happens when you try? Can you add individual annotations to a note from the PDF readers? Does "Add Item Note from Annotations" work in the PDF readers?

    This isn't a general issue, it works fine for me in Z7
  • Yes, nothing happens

    Add Item Note from Annotations ... not sure what this means. I'm using the internal Zotero PDF reader. I'm not sure where the command/option is that you write about? Zotero main window? Within the PDF reader? At any rate ... not seeing it.

    Also don't know what you mean by "add individual annotations to a note from the PDF readers". Within the PDF Zotero reader I can easily add annotations. But guessing this isn't what you really mean.
  • If you have the PDF Reader open, click on the note icon at the top right to open the note view, the "Add Item Note from Annotations" option (which does the same thing as the "Add Notes..." option) is available as one of two options under the + sign

    Again in the note view of the PDF Reader, if you have a note open on the right, right-clicking on any annotation either on the left or in the reader gives you an "Add to Note" option.
  • @adamsmith: First, this is great to know the Add Notes from Annotations feature does work in Beta 7. Thanks also for the additional info.

    Yes, in PDF Reader both of your suggested alternatives work. That's great! Thanks for the detailed explanation.

    So I have gone back to the "regular" view and tried the Add Note from Annotations option when selecting an article/citation. And it works!

    ... then I went to a new article. Did an annotation. Tried Add Note from Annotations and, once again, it did not work. However, if I went into PDF view and added the annotations via Note view that was fine. And, then, if I added a new annotation, went back to regular view and tried Add Note from Annotations then it now works!

    So it seems, for me, in V7 I need to "prime" this add note feature in PDF view before it will work in regular view.

    I will restart my computer later today (I had Zotfile installed in v6, and removed it this morning). I am using a MacBookAir 15 ... so on a Silicon chip with Ventura 13.4. (This may not make any difference, just providing the info in case useful.)

  • Restart did not change the behavior. Problem is only when in regular view. No problems in PDF view.
  • Could you provide a debug ID for a failed Add Notes from Annotation attempt?
  • @adamsmith: If I did everything correctly the result is: Debug ID D1869423633

    The report has been submitted.
Sign In or Register to comment.