Zotero fails to launch on Mac

I have installed Zotero on my Mac (OS 11.7.7) but Zotero fails to launch.
After attempting to launch, the Zotero icon bonces in the dock for a couple of minutes and then stops. The application window does not appear and there is no error message. There is no "dot" below the icon and pressing cmd+tab does not display Zotero among the running applications. Right-clicking the icon in the dock allows me to "Force Quit".

I have tried the current release 6.0.26, 6.0.23 as well as the beta release 7.0.0 with identical results.

Can you help?
  • Have you tried restarting your computer? Both Zotero 6 and Zotero 7 certainly run on Big Sur.
  • Yes, I have restarted the computer several times. Also I checked for MacOS updates but it is up to date.
  • What happens if you run this in Terminal, with Zotero 7?

    /Applications/Zotero.app/Contents/MacOS/zotero -ZoteroDebugText
  • Running the command in Terminal does not seem to do anything. There is no error message in the Terminal and no .txt file on the Desktop.
  • edited June 8, 2023
    That command just starts Zotero with logging to the terminal. It doesn't create a text file.

    If you add -P, does it open the profile manager?

    Do you see crash reports in the Console app?
  • Yes, this opened a box named "Zotero - Choose User Profile"
    and in the Terminal:
    2023-06-08 09:43:33.529 zotero[1562:14036] *** WARNING: Textured window is getting an implicitly transparent titlebar. This will break when linking against newer SDKs. Use NSWindow's -titlebarAppearsTransparent=YES instead.
  • OK, and if you run that (along with -ZoteroDebugText) and select your profile, nothing is logged to Terminal, and, what, it hangs? Quits?

    And my question about Console?
  • There was/is no crash report in the Console.

    From the profile manager I was able to create a profile and start Zotero.
    I have successfully added a paper using the Chrome Connector and then adding a .pdf.
    I have closed Zotero and successfully relaunched the application and everything seems to be working.

    Apparently, the work around was to launch the profile manager using
    /Applications/Zotero.app/Contents/MacOS/zotero -ZoteroDebugText -P
    and launch Zotero from there. Maybe importantly, I did this just after restarting my Mac again.

    Thank you for your help!
  • From the profile manager I was able to create a profile and start Zotero.
    Wait, meaning there was no profile listed there when you first opened the profile manager?

    Had you run Zotero on this computer before? I don't think we've ever heard of a profile not being automatically created.
  • edited June 8, 2023
    Exactly, the list was empty! And no, I have not rund Zotero and the computer before.

    I have been running Papers apps in different versions which have similar user interfaces, but could these be able to conflict with Zotero?
Sign In or Register to comment.