[Feature suggestion: Zotero 7+] Split View in MacOS

edited May 28, 2023
First-off: THANK YOU for the 7 beta, everything feels so snappy and quick.

This is not a bug: It'd be great, for a full immersive experience when writing and doing research, that Zotero can be made compatible with MacOS's split view. https://support.apple.com/en-us/HT204948

Much obliged!

Edit: ensure that you have already carefully consulted apple's guide above!
  • It is already compatible
  • @poettli
    I'm not sure.. see attached screenshot of the options when hover around the green button on the menu bar. https://i.imgur.com/CNK5FbW.png

    Note that it doesn't say "Tile Window to Left of Screen” or ”Tile Window to Right of Screen” from the menu" per apple's website. And, I tried manually merging two full-screened apps, it doesn't work.
  • edited May 28, 2023
    OK. I see now I wen too fast. I can put zotero to the left or the right, but no other application is offered to be opened in the other side, as it should be. So yes, there is a problem
  • I don't use Split View, but I'm not seeing a problem here. In Zotero 7, I have "Tile Window to Left of Screen" and "Tile Window to Right of Screen" when hovering over the green button. If I put it on either side, I can then click on any other window in the other half of the screen and interact with both.
  • edited May 28, 2023
  • Thanks @poettli - I had not realised that this is perhaps a Apple Silicon problem (which is why I flagged my issue as feature request), your painstaking troubleshooting convinced me otherwise.

    @dstillman It seems now that it is a bug but I sadly cannot help further with diagnosis for I only have one machine at hand... Nevertheless, sorry for the nit-picking.
  • No, nothing to do with Apple Silicon — it’s working for me on two different Apple Silicon Macs.
  • Mystery solved, I had “Displays have separate Spaces” is turned off. Apologies everyone.
  • I already had “Displays have separate Spaces” turned on when I tried yesterday. A restart of the laptop solved the problem for me.
Sign In or Register to comment.