iOS/iPadOS Zotero share function only adds reference but does not dowload pdfs after uni switch

Dear Zotero elders,
Zotero worked perfectly fine with my previous university (until end of april), but now that I switched to the University of Vienna the iOS and iPadOS app does not download pdfs for references anymore AT ALL. On my mac everything works after settings proxies and the resolver, but not on my iPad and iPhone. I suspect that it might have to do something with the way the University of Vienna authorises to the journal websites. It seems the proxy the University of Vienna uses "confused" my iPhone/iPad. Does anyone have an idea how to make it work again? (I already tried reinstalling Zotero on my iPhone/iPad, it did not help).

** Situation: **
I want to download a reference AND its PDF, say: (1st URL)

The library of the University of Vienna suggests (see here: to make a bookmark that runs a java script that changes the URL to this: (2nd URL)

This link opens a log in page from the University of Vienna and then after log in, gets me back to the journal website and there I have full access to the paper (after a painfully slow process of reloading the page), which is indicated by a banner "Access By Vienna University Library" at the top of the page as well as a symbol with an open lock and "full access" in green letters. So far so good. What works on all devices and browsers is that I can open the PDF by clicking on the PDF symbol of the journal website, which in the example case opens: (3rd URL)

Note that this is independent of the browser I use (firefox, safari, chrome) and also of the VPN connection and it is the same on mac/iOS/iPadOS. The only difference is that on mac there is the Zotero connector app which understands that it needs to set a proxy and shows me a banner on proxy settings – this does not happen on iOS/iPadOS, because there is no Connector extension. On mac, my firefox Zotero conncector proxy settings are:

** Problem: **
What does work on mac, but not on iPadOS/iOS is that Zotero does not download the PDF when clicking on the share button from this page:

It does download the Metadata, and it also shows the animation about downloading the PDF but then when I check in the database there is no PDF.

What is worse is that on iPadOS/iOS my Zotero app currently does not even download PDFs when there is no paywall!!! Say, for example this publicly available paper on SSRN:

I am puzzled, help!
  • The SSRN PDF just isn't working in the iOS app at the moment. We'll investigate.

    For Wiley, can you provide a Debug ID for reproducing this?
  • edited May 26, 2023
    Thanks for the super quick answer! Here a Debug ID:

    EDIT: could it have something to do with the Automatic Zotero iOS Client Key? It seems that changed in the last weeks.
Sign In or Register to comment.